On Thu, Aug 03, 2006 at 08:58:52AM +0200, Martin Waitz wrote: > we could make the default use %ENV. > > Something like (in Makefile): > > GITWEB_SITENAME = $$ENV{GITWEB_SITENAME} > GITWEB_PROJECTROOT = $$ENV{GITWEB_SITENAME} || "/pub/git" An interesting idea, but it means that gitweb.perl no longer parses as valid perl, since we have things like: > our $projectroot = @@GITWEB_PROJECTROOT@@; Do the environment variable names really need to be configurable, or would something like this work: 1. accept from config file if it exists and defines $projectroot 2. otherwise, accept from environment if GITWEB_PROJECTROOT is defined 3. otherwise, default to compile-time value Speaking of which, perhaps we should clean up the names of variables that are used by the config file now, before they get into widespread use. The names are very inconsistent (e.g., projectroot, git_temp) and undocumented. We could standardize on something like $GITWEB_PROJECTROOT, matched to GITWEB_PROJECTROOT in the environment and GITWEB_PROJECTROOT in the Makefile. -Peff - : send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html