Henrik Akesson wrote: > Here's a patch for: > > - Documentation and debug statements added > - Removed needs_visiting from the gegl-visitable interface and the > implementing classes gegl-pad and gegl-node because it was not used > (hardcoded to return TRUE). > - Refactored gegl-eval-mgr field "state" to use an enumeration instead > of integers for improving readability of the code. Thanks! I have split up the patch in three separate commits and commited. I left out the g_debug() debug code for now since it is enabled by default which is too intrusive IMO, I think such output should require setting a flag before it's enabled. - Martin 2009-03-18 Martin Nordholts <martinn@xxxxxxxxxxxxx> Apply patch from Henrik Akesson that turns GeglEvalMgr::state into an enum instead of using pure ints since that increases readability. * gegl/process/gegl-eval-mgr.[ch] 2009-03-18 Martin Nordholts <martinn@xxxxxxxxxxxxx> Apply patch from Henrik Akesson that adds documentation to the graph parts of the GEGL core in form of comments. * gegl/graph/gegl-node.c * gegl/graph/gegl-visitor.c * gegl/operation/gegl-operation.c * gegl/process/gegl-cr-visitor.c * gegl/process/gegl-eval-mgr.[ch] * gegl/process/gegl-have-visitor.c * gegl/process/gegl-prepare-visitor.c 2009-03-18 Martin Nordholts <martinn@xxxxxxxxxxxxx> Apply patch from Henrik Akesson that removes the superfluous GeglVisitableClass::needs_visiting() and all code that depends on it such as the GeglNode and GeglPad implementations (both of which just returned TRUE) and the calls to the method. * gegl/graph/gegl-node.c * gegl/graph/gegl-pad.c * gegl/graph/gegl-visitable.[ch] * gegl/graph/gegl-visitor.c _______________________________________________ Gegl-developer mailing list Gegl-developer@xxxxxxxxxxxxxxxxxxxxxx https://lists.XCF.Berkeley.EDU/mailman/listinfo/gegl-developer