I am doing some serious API renaming in GEGL due to merging of GeglGraph and GeglNode classes. The reason I'm doing the merging is that it seems to make it cleaner when writing a ruby binding, and that part of the code has some issues with using inheritance without transmogrification. The global replacements I've done are: s/gegl_graph_/gegl_node_/ s/gegl_node_new_node/gegl_node_new_child/ s/gegl_node_create_node/gegl_node_create_child/ s/gegl_node_input/gegl_node_get_input_proxy/ s/gegl_node_output/gegl_node_get_output_proxy/ Any comments? My plan is to push out 0.0.6 which will contain touch ups of the API as well as the build changes that have already gone into the tree this weekend. (PS: for a more up to date with svn version of the GEGL documentation see http://pippin.gimp.org/gegl/ , the version at http://gegl.org/ will probably in the future document the last tarball release.) /Øyvind K. -- «The future is already here. It's just not very evenly distributed» -- William Gibson http://pippin.gimp.org/ http://ffii.org/ _______________________________________________ Gegl-developer mailing list Gegl-developer@xxxxxxxxxxxxxxxxxxxxxx https://lists.XCF.Berkeley.EDU/mailman/listinfo/gegl-developer