> -----Original Message----- > From: Alexey Dobriyan <adobriyan@xxxxxxxxx> > Sent: Sunday, February 14, 2021 2:15 PM > To: axboe@xxxxxxxxx > Cc: fio@xxxxxxxxxxxxxxx > Subject: [PATCH] fio: simplify parse_is_percent() fio: -> parse:? > > Check like this > > unsigned long long val <= -1ULL > > is tautologically true because of how type conversions work. > > Signed-off-by: Alexey Dobriyan <adobriyan@xxxxxxxxx> > --- > > parse.h | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > --- a/parse.h > +++ b/parse.h > @@ -131,7 +131,7 @@ static inline void *td_var(void *to, const struct > fio_option *o, > > static inline int parse_is_percent(unsigned long long val) > { > - return val <= -1ULL && val >= (-1ULL - 100ULL); > + return val >= -101; Nice cleanup, but wouldn't that be better to keep the ULL suffix for the sake of clarity? > } > > #define ZONE_BASE_VAL ((-1ULL >> 1) + 1) This patch is based on your earlier patch "zbd: support 'z' suffix for zone granularity" that is still in review, why not to combine these two in a series?