[Fedora-tools-list] backward compatibility issue

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I have been trying to get VCS to run with Fedora Core 3. Since VCS was
supporting enterprise 3.0. I took the compat-gcc and compat-glibc source
rpms from enterprise 4.0 and built them with the fedora libs. That
worked so I then installed them which also worked. I then added -
L /usr/lib/i386-redhat-linux3E/lib to the link line for VCS. 
But I still get the same link error as without the compat libs. See
Below. Anyone know what I have done wrong??
gcc   -o ../tst02.ulogsim -L/usr/lib/i386-redhat-linux3E  dqc7_1_d.o
6AsL_1_d.o pXJr_1_d.o kEvb_1_d.o ZcgZ_1_d.o ePdM_1_d.o pk44_1_d.o
80pP_1_d.o mVzK_1_d.o BpXX_1_d.o nKcx_1_d.o CGvf_1_d.o hGNm_1_d.o
ThmQ_1_d.o 2DNG_1_d.o fKxI_1_d.o AsAT_1_d.o MKow_1_d.o dBQ4_1_d.o
yrsW_1_d.o 74Ed_1_d.o vjjS_1_d.o rVE8_1_d.o avTK_1_d.o B38d_1_d.o
JYvm_1_d.o BqCG_1_d.o 4Y70_1_d.o rw0a_1_d.o J80T_1_d.o YO9T_1_d.o
GVev_1_d.o ZeX5_1_d.o Yiy0_1_d.o wc8Y_1_d.o BfWx_1_d.o IDCi_1_d.o
coEB_1_d.o XrSE_1_d.o KTMW_1_d.o F3JL_1_d.o 47xh_1_d.o 4aK9_1_d.o
ieM5_1_d.o BUI4_1_d.o KW5l_1_d.o TOIy_1_d.o A2eH_1_d.o Ztjj_1_d.o
Mfgv_1_d.o 1ngE_1_d.o rVTC_1_d.o 6Yso_1_d.o rnou_1_d.o lmTC_1_d.o
7SMt_1_d.o YNhq_1_d.o qX2z_1_d.o RhF7_1_d.o 2MHE_1_d.o mtk8_1_d.o
qs66_1_d.o RuJz_1_d.o nLlM_1_d.o hGsl_1_d.o MALM_1_d.o 57S2_1_d.o
FzPU_1_d.o RPzz_1_d.o 7s2c_1_d.o lXAs_1_d.o mJhD_1_d.o 613w_1_d.o
tjBY_1_d.o C45n_1_d.o xz6M_1_d.o aFn1_1_d.o OpVV_1_d.o m6E0_1_d.o
i9uP_1_d.o T4Fb_1_d.o 2jkG_1_d.o g60C_1_d.o B7YD_1_d.o fstp_1_d.o
Iiuq_1_d.o yRyV_1_d.o TH8N_1_d.o Dexz_1_d.o SIM_l.o 5NrI_d.o
5NrIB_d.o   /opt/vcs7.2/gui/virsim/linux/vcdplus/vcs7_2/libvirsim.a /home/lgliem/libs/libmap3sim/user_common/libvcssim.a     /opt/vcs7.2/linux/lib/libvcsnew.so     -ldl -lm  -lc -ldl   
+0x2ec2a): In function `vs_clStrCmpCI(char *, char *)':
: undefined reference to `__ctype_toupper'
+0x2ec8f): In function `vs_clStrCmpCI(char *, char *)':
: undefined reference to `__ctype_toupper'
+0x2eca8): In function `vs_clStrCmpCI(char *, char *)':
: undefined reference to `__ctype_toupper'
+0x2ed05): In function `vs_clStrToLower(char *)':
: undefined reference to `__ctype_tolower'
+0x2f035): In function `vs_clStrToUpper(char *)':
: undefined reference to `__ctype_toupper'
collect2: ld returned 1 exit status
make[2]: *** [product_timestamp] Error 1

[Index of Archives]     [GCC Help]     [Fedora Development]     [Fedora Announce]     [Fedora Legacy Announce]     [Home]     [Fedora Config]     [PAM]     [Red Hat 9]     [Big List of Linux Books]     [Gimp]     [Yosemite News]

  Powered by Linux