[Bug 2112474] Review Request: python-qemu-qmp - QEMU Monitor Protocol library

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



https://bugzilla.redhat.com/show_bug.cgi?id=2112474



--- Comment #29 from Maxwell G <gotmax@e.email> ---
```
PATH="%{buildroot}%{_bindir}:$PATH" \
PYTHONPATH="${PYTHONPATH:-%{buildroot}%{python3_sitearch}:%{buildroot}%{python3_sitelib}}"
\
_PYTHONSITE="%{buildroot}%{python3_sitearch}:%{buildroot}%{python3_sitelib}" \
PYTHONDONTWRITEBYTECODE=1 \
```

That's mostly fine. If you'd like you can simplify it to

```
export PYTHONPATH=%{buildroot}%{python3_sitelib}
export PYTHONDONTWRITEBYTECODE=1
export PATH="%{buildroot}%{_bindir}:${PATH}"
avocado --config avocado.cfg run tests/*.py
```

You can remove the "${PYTHON:...}" parameter expansion. That's there in
`%pytest` so a user can override the variable before invoking the the macro,
which isn't needed here. You can also remove `%{buildroot}%{python_sitearch}`
here, because the package doesn't install anything there. That's in the macro
to make it work with both noarch and arched packages, but this package is
noarch.

```
mkdir -p %{buildroot}%{_mandir}/man1
install -m 0644 man/*.1 %{buildroot}%{_mandir}/man1/
```

You need to pass the `-p` argument to install to preserve mtimes. I prefer to
combine the `mkdir` and `install` into one command, but that's optional:

```
install -Dpm 0644 man/*.1 -t %{buildroot}%{_mandir}/man1/
```

Nitpicks:

> %{pyproject_check_import -e qemu.qmp.qmp_tui}

The `%pyproject_check_import -e qemu.qmp.qmp_tui` syntax is preferred here, but
meh.

```
%package -n     python3-qemu-qmp
Summary:        %{summary}
%description -n python3-qemu-qmp %_description
```

The subpackage definitions would be more readable if you added a new line or
two before `%description`.


-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are always notified about changes to this product and component
https://bugzilla.redhat.com/show_bug.cgi?id=2112474
_______________________________________________
package-review mailing list -- package-review@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to package-review-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/package-review@xxxxxxxxxxxxxxxxxxxxxxx
Do not reply to spam, report it: https://pagure.io/fedora-infrastructure/new_issue




[Index of Archives]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite Conditions]     [KDE Users]

  Powered by Linux