Re: Can't list directories with kernel 4.4.14 and ecryptfs

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 06/27/2016 04:21 PM, Henry Jensen wrote:
> Hi Tyler,
> Am 27. Juni 2016 21:19:08 MESZ, schrieb Tyler Hicks <tyhicks@xxxxxxxxxxxxx>:
>> On 06/27/2016 11:27 AM, Henry Jensen wrote:
>>> Greetings,
>>> I'm using ecryptfs with Slackware current and kernel 4.4.14. In
>> kernel
>>> 4.4.14 was a patch introduced which make it impossilble to list the
>>> contents of a directory.[0]
>>> The mount itself works, but listing a directory results in an error
>>> "wrong medium type". Showing the contents and the file itself
>> (presumed
>>> the name of the file is known) works.
>> Hi Henry - sorry for the trouble. What filesystem are you mounting
>> eCryptfs on top of?
> I use ext4. With 'ecryptfs-mount-private' $HOME/.Private is mounted on $HOME/Private. 
> ecryptfs worked perfectly until I upgraded to kernel 4.4.14. I tested it on another machine with Slackware64 and a 64bit kernel now - same result.

Thanks. The backported version of the patch needs to be adjusted. I'll
try to get a patch out the stable list tomorrow.


> Regards,
> Henry
> --
> To unsubscribe from this list: send the line "unsubscribe ecryptfs" in
> the body of a message to majordomo@xxxxxxxxxxxxxxx
> More majordomo info at

Attachment: signature.asc
Description: OpenPGP digital signature

[Index of Archives]     [Linux Crypto]     [Device Mapper Crypto]     [LARTC]     [Bugtraq]     [Yosemite Forum]

  Powered by Linux