Re: [PATCH 00/10] libdrm amdgpu patches

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Am 12.01.2016 um 22:30 schrieb Alex Deucher:
On Tue, Jan 12, 2016 at 4:23 PM, Marek Olšák <maraeo@xxxxxxxxx> wrote:
Hi,

These are libdrm_amdgpu patches harvested from an internal branch.

The first patch is a revert I had to make to fix the build. Yeah, sequence_mutex should be renamed to a more appropriate name. That can be done as a follow-up.

One notable change is the addition of DRM_IOCTL_AMDGPU_WAIT_FENCES. I hope the kernel contains (or will contain) the changes too, so that I don't push something that doesn't exist in the kernel.
We haven't pushed DRM_IOCTL_AMDGPU_WAIT_FENCES upstream yet so I would
hold off on any changes that depend on that.

Yeah, and do we really have patch #9 in our internal branch without an Review? Cause that one breaks the API.

Christian.


Alex

Please let me know if these are okay to push.

Thanks,

Chunming Zhou (3):
       amdgpu: add semaphore support
       tests/amdgpu: add semaphore test
       amdgpu: validate user memory for userptr

Junwei Zhang (3):
       amdgpu: add the interface of waiting multiple fences
       amdgpu/tests: add multi-fence test in base test
       amdgpu: list each entry safely for sw semaphore when submit ib

Marek Olšák (1):
       Revert "amdgpu: remove sequence mutex"

Michel Dänzer (1):
       amdgpu: Cast pointer to uintptr_t for assignment to unsigned integer

monk.liu (2):
       amdgpu: drop address patching logics
       amdgpu: cs_wait_fences now can return the first signaled fence index

  amdgpu/amdgpu.h            |  88 +++++++++++++++++++++++++++++++++++++++++
  amdgpu/amdgpu_bo.c         |  14 ++-----
  amdgpu/amdgpu_cs.c         | 253 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++--
  amdgpu/amdgpu_internal.h   |  15 +++++++
  include/drm/amdgpu_drm.h   |  28 +++++++++++++
  tests/amdgpu/basic_tests.c | 233 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
  6 files changed, 616 insertions(+), 15 deletions(-)

Marek
_______________________________________________
dri-devel mailing list
dri-devel@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/dri-devel
_______________________________________________
dri-devel mailing list
dri-devel@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/dri-devel

_______________________________________________
dri-devel mailing list
dri-devel@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/dri-devel




[Index of Archives]     [Linux DRI Users]     [Linux Intel Graphics]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux