On Fri, Dec 20, 2013 at 03:08:21PM +0200, Jani Nikula wrote: > On Tue, 17 Dec 2013, Thierry Reding <thierry.reding@xxxxxxxxx> wrote: [...] > > +/** > > + * drm_dp_dpcd_writeb() - write a single byte to the DPCD > > + * @aux: DisplayPort AUX channel > > + * @offset: address of the register to write > > + * @valuep: value to write to the register > > + * > > + * Returns the number of bytes transferred (1) on success, or a negative > > + * error code on failure. > > + */ > > +static inline ssize_t drm_dp_dpcd_writeb(struct drm_dp_aux *aux, u8 value, > > + unsigned int offset) > > I'd much prefer offset before value parameter. Why would you have these > the other way around here than in all the other functions? I guess I thought this would mirror the convention seen with readl() and writel(), but I suppose since drm_dp_dpcd_readb() doesn't actually look anything like readl() there's no consistency here anyway. I'll change it around. Thierry
Attachment:
pgp_DAhZgKl4u.pgp
Description: PGP signature
_______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/dri-devel