On Fri, Nov 22, 2024 at 11:12:58AM +0200, Dmitry Baryshkov wrote: > As pointed out by Maxime, the drm_atomic_helper_connector_hdmi_init() > isn't a good name for a function inside KUnit tests. Rename it to > drm_kunit_helper_connector_hdmi_init(). > > Suggested-by: Maxime Ripard <mripard@xxxxxxxxxx> > Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx> > --- > drivers/gpu/drm/tests/drm_hdmi_state_helper_test.c | 58 +++++++++++----------- > 1 file changed, 29 insertions(+), 29 deletions(-) > > diff --git a/drivers/gpu/drm/tests/drm_hdmi_state_helper_test.c b/drivers/gpu/drm/tests/drm_hdmi_state_helper_test.c > index 1e77689af6549f162eb3026c7bd2bbd59516ed98..d81254d46975e8af0d782249928217a1ebb7646e 100644 > --- a/drivers/gpu/drm/tests/drm_hdmi_state_helper_test.c > +++ b/drivers/gpu/drm/tests/drm_hdmi_state_helper_test.c > @@ -164,7 +164,7 @@ static const struct drm_connector_funcs dummy_connector_funcs = { > > static > struct drm_atomic_helper_connector_hdmi_priv * > -drm_atomic_helper_connector_hdmi_init(struct kunit *test, > +drm_kunit_helper_connector_hdmi_init(struct kunit *test, > unsigned int formats, > unsigned int max_bpc) > { > @@ -247,7 +247,7 @@ static void drm_test_check_broadcast_rgb_crtc_mode_changed(struct kunit *test) > struct drm_crtc *crtc; > int ret; > > - priv = drm_atomic_helper_connector_hdmi_init(test, > + priv = drm_kunit_helper_connector_hdmi_init(test, > BIT(HDMI_COLORSPACE_RGB), > 8); The alignment is off now. With that fixed, Reviewed-by: Maxime Ripard <mripard@xxxxxxxxxx> Maxime
Attachment:
signature.asc
Description: PGP signature