On Tue, 29 Oct 2024 at 20:08, Abhinav Kumar <quic_abhinavk@xxxxxxxxxxx> wrote: > > > > On 10/28/2024 4:49 AM, Dmitry Baryshkov wrote: > > Follow the estalished prefix and rename eDP bridge symbols to use > > msm_dp_ prefix, moving the edp to the end of the symbol name. > > > > Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx> > > --- > > drivers/gpu/drm/msm/dp/dp_drm.c | 36 ++++++++++++++++++------------------ > > 1 file changed, 18 insertions(+), 18 deletions(-) > > > > diff --git a/drivers/gpu/drm/msm/dp/dp_drm.c b/drivers/gpu/drm/msm/dp/dp_drm.c > > index 6a0840266c0f..ff9ce9b15234 100644 > > --- a/drivers/gpu/drm/msm/dp/dp_drm.c > > +++ b/drivers/gpu/drm/msm/dp/dp_drm.c > > @@ -115,7 +115,7 @@ static const struct drm_bridge_funcs msm_dp_bridge_ops = { > > .debugfs_init = msm_dp_bridge_debugfs_init, > > }; > > > > -static int edp_bridge_atomic_check(struct drm_bridge *drm_bridge, > > +static int msm_dp_bridge_atomic_check_edp(struct drm_bridge *drm_bridge, > > struct drm_bridge_state *bridge_state, > > struct drm_crtc_state *crtc_state, > > struct drm_connector_state *conn_state) > > msm_dp_bridge_atomic_check_edp looks a bit odd. > > What about just msm_edp_bridge_atomic_check? > > Likewise for other edp names. Yeah, I was torn between these two options. I'll switch to the second one. -- With best wishes Dmitry