To simplify the memory managment this series replace all allocation by drm-managed one. This way the VKMS code don't have to manage it directly and the DRM core will handle the object destruction. No functional changes are intended in this series. PATCH 1/6: Migrate connector managment to drm PATCH 2/6: Migrate encoder managment to drm PATCH 3/6: Rename vkms_output to vkms_crtc PATCH 4/6: Rename to_vkms_crtc_state PATCH 5/6: Migrate connector management to drm PATCH 6/6: Add missing check in CRTC initialization This series have conflicts with [1], which adds documentation for the vkms_output/vkms_crtc structure. when one of those series is merged, I will rebase the other. [1]: https://lore.kernel.org/all/20240826-google-clarifications-v2-1-2574655b0b91@xxxxxxxxxxx/ Signed-off-by: Louis Chauvet <louis.chauvet@xxxxxxxxxxx> --- Changes in v2: - Applied comments from José - Extract the rename vkms_output -> vkms_crtc to avoid useless changes in the last commit - Extract the rename to_vkms_crtc_state to drm_crtc_state_to_vkms_crtc_state to avoid useless changes in last commit - Extract the drm_mode_crtc_set_gamma_size result check in its own commit - Rebased on drm-misc/drm-misc-next - Link to v1: https://lore.kernel.org/r/20240814-google-vkms-managed-v1-0-7ab8b8921103@xxxxxxxxxxx --- Louis Chauvet (6): drm/vkms: Switch to managed for connector drm/vkms: Switch to managed for encoder drm/vkms: Rename vkms_output to vkms_crtc drm/vkms: rename to_vkms_crtc_state to drm_crtc_state_to_vkms_crtc_state to avoid confusion drm/vkms: Switch to managed for CRTC drm/vkms: Add missing check for CRTC initialization drivers/gpu/drm/vkms/vkms_composer.c | 30 +++++----- drivers/gpu/drm/vkms/vkms_crtc.c | 97 ++++++++++++++++++-------------- drivers/gpu/drm/vkms/vkms_drv.c | 11 +--- drivers/gpu/drm/vkms/vkms_drv.h | 21 +++---- drivers/gpu/drm/vkms/vkms_output.c | 101 ++++++++++++++++------------------ drivers/gpu/drm/vkms/vkms_writeback.c | 22 ++++---- 6 files changed, 138 insertions(+), 144 deletions(-) --- base-commit: 071d583e01c88272f6ff216d4f867f8f35e94d7d change-id: 20240521-google-vkms-managed-4aec99461a77 Best regards, -- Louis Chauvet <louis.chauvet@xxxxxxxxxxx>