On Wed, Aug 21, 2024 at 02:16:21PM -0600, Gustavo A. R. Silva wrote: > Use the `DEFINE_RAW_FLEX()` helper for an on-stack definition of > a flexible structure where the size of the flexible-array member > is known at compile-time, and refactor the rest of the code, > accordingly. > > So, with this, fix the following warning: > > drivers/gpu/drm/nouveau/dispnv50/disp.c:779:47: warning: structure containing a flexible array member is not at the end of another structure [-Wflex-array-member-not-at-end] > > Signed-off-by: Gustavo A. R. Silva <gustavoars@xxxxxxxxxx> > --- > drivers/gpu/drm/nouveau/dispnv50/disp.c | 20 +++++++++----------- > 1 file changed, 9 insertions(+), 11 deletions(-) > > diff --git a/drivers/gpu/drm/nouveau/dispnv50/disp.c b/drivers/gpu/drm/nouveau/dispnv50/disp.c > index eed579a6c858..ddddc69640be 100644 > --- a/drivers/gpu/drm/nouveau/dispnv50/disp.c > +++ b/drivers/gpu/drm/nouveau/dispnv50/disp.c > @@ -774,11 +774,9 @@ nv50_hdmi_enable(struct drm_encoder *encoder, struct nouveau_crtc *nv_crtc, > struct drm_hdmi_info *hdmi = &nv_connector->base.display_info.hdmi; > union hdmi_infoframe infoframe = { 0 }; > const u8 rekey = 56; /* binary driver, and tegra, constant */ > + DEFINE_RAW_FLEX(struct nvif_outp_infoframe_v0, args, data, 17); > + const u8 data_len = 17; /* same length as in DEFINE_RAW_FLEX above. */ To avoid repeating the open-coded "17", this could either be a define: nv50_hdmi_enable(...) { ... #define data_len 17 DEFINE_RAW_FLEX(struct nvif_outp_infoframe_v0, args, data, data_len); ...rest of function... #undef data_len } or an ungainly but compile-time calculated value that exposes some DEFINE_FLEX internals: const u8 data_len = (sizeof(args_u) - sizeof(*args)) / sizeof(*args->data); (Maybe a helper is needed for that?) #define STACK_FLEX_COUNT(name, member) \ ((sizeof(name##_u) = sizeof(*(name))) / sizeof(*(name)->member)) > @@ -815,29 +813,29 @@ nv50_hdmi_enable(struct drm_encoder *encoder, struct nouveau_crtc *nv_crtc, > return; > > /* AVI InfoFrame. */ > - args.infoframe.version = 0; > - args.infoframe.head = nv_crtc->index; > + args->version = 0; > + args->head = nv_crtc->index; The stack variable (was before and is again) already zero-initialized, so the "= 0" line shouldn't be needed. But neither of these comments are show-stoppers, IMO. Reviewed-by: Kees Cook <kees@xxxxxxxxxx> -- Kees Cook