[PATCH 2/2] udmabuf: make udmabuf folios and offsets set more readable

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



The current code for setting folios and offsets is not very readable.

In fact, udmabuf->folios represents the head page of each folio, while
the offset indicates the PAGE_SIZE offset within the folio for the
corresponding pgcnt. And folios only add head page(the folio) into unpin
list.

This patch changes the loop condition to use folios as the outer loop
and sets the subpages of the folio in the inner loop, making it easier
to understand the relationship between unpin and folios/offset.

The loop conditions for j and k are actually only used in the head loop,
so they can be turned into loop variables.

Signed-off-by: Huan Yang <link@xxxxxxxx>
---
 drivers/dma-buf/udmabuf.c | 40 ++++++++++++++++++++-------------------
 1 file changed, 21 insertions(+), 19 deletions(-)

diff --git a/drivers/dma-buf/udmabuf.c b/drivers/dma-buf/udmabuf.c
index 6604d91e7072..0285194e6b51 100644
--- a/drivers/dma-buf/udmabuf.c
+++ b/drivers/dma-buf/udmabuf.c
@@ -301,7 +301,7 @@ static long udmabuf_create(struct miscdevice *device,
 	struct file *memfd = NULL;
 	struct folio **folios;
 	struct udmabuf *ubuf;
-	u32 i, j, k, flags;
+	u32 i, flags;
 	loff_t end;
 
 	ubuf = kzalloc(sizeof(*ubuf), GFP_KERNEL);
@@ -338,6 +338,7 @@ static long udmabuf_create(struct miscdevice *device,
 
 	pgbuf = 0;
 	for (i = 0; i < head->count; i++) {
+		u32 j, k;
 		memfd = fget(list[i].memfd);
 		ret = check_memfd_seals(memfd);
 		if (ret < 0)
@@ -360,26 +361,27 @@ static long udmabuf_create(struct miscdevice *device,
 			goto err;
 		}
 
-		nr_folios = ret;
-		pgoff >>= PAGE_SHIFT;
-		for (j = 0, k = 0; j < pgcnt; j++) {
-			ubuf->folios[pgbuf] = folios[k];
-			ubuf->offsets[pgbuf] = pgoff << PAGE_SHIFT;
-
-			if (j == 0 || ubuf->folios[pgbuf-1] != folios[k]) {
-				ret = add_to_unpin_list(&ubuf->unpin_list,
-							folios[k]);
-				if (ret < 0) {
-					kfree(folios);
-					goto err;
-				}
+		/**
+		 * Iter each folios we got from pin, add each folio into unpin
+		 * list and setup each folio and page offset into folio into
+		 * corrent page count position.
+		 * So that we can iter any offset in size and get correctly
+		 * page.
+		 */
+		for (j = 0, pgoff >>= PAGE_SHIFT, nr_folios = ret;
+		     j < nr_folios; ++j, pgoff = 0) {
+			long nr_pages;
+
+			ret = add_to_unpin_list(&ubuf->unpin_list, folios[j]);
+			if (ret < 0) {
+				kfree(folios);
+				goto err;
 			}
 
-			pgbuf++;
-			if (++pgoff == folio_nr_pages(folios[k])) {
-				pgoff = 0;
-				if (++k == nr_folios)
-					break;
+			for (k = 0, nr_pages = folio_nr_pages(folios[j]);
+			     k < nr_pages; ++k, ++pgoff, ++pgbuf) {
+				ubuf->folios[pgbuf] = folios[j];
+				ubuf->offsets[pgbuf] = pgoff << PAGE_SHIFT;
 			}
 		}
 
-- 
2.45.2




[Index of Archives]     [Linux DRI Users]     [Linux Intel Graphics]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux