On Fri, 28 Jun 2024, Imre Deak <imre.deak@xxxxxxxxx> wrote: > This is v2 of [1], renaming the helpers from drm_x16 to fxp_q4 as > suggested by Jani. > > [1] https://lore.kernel.org/all/20240614173911.3743172-1-imre.deak@xxxxxxxxx > > Cc: Jani Nikula <jani.nikula@xxxxxxxxx> No detailed review, but on the approach and naming, Acked-by: Jani Nikula <jani.nikula@xxxxxxxxx> > > Imre Deak (9): > drm: Add helpers for q4 fixed point values > drm/display/dsc: Add a helper to dump the DSC configuration > drm/i915: Replace to_bpp_x16() with fxp_q4_from_int() > drm/i915: Replace to_bpp_int() with fxp_q4_to_int() > drm/i915: Replace to_bpp_int_roundup() with fxp_q4_to_int_roundup() > drm/i915: Replace to_bpp_frac() with fxp_q4_to_frac() > drm/i915: Replace BPP_X16_FMT()/ARGS() with FXP_Q4_FMT()/ARGS() > drm/i915: Dump DSC state to dmesg and debugfs/i915_display_info > drm/i915: Remove DSC register dump > > drivers/gpu/drm/display/drm_dp_helper.c | 5 +- > drivers/gpu/drm/display/drm_dsc_helper.c | 91 +++++++++++++++++++ > drivers/gpu/drm/i915/display/icl_dsi.c | 9 +- > drivers/gpu/drm/i915/display/intel_audio.c | 5 +- > drivers/gpu/drm/i915/display/intel_bios.c | 5 +- > drivers/gpu/drm/i915/display/intel_cdclk.c | 5 +- > .../drm/i915/display/intel_crtc_state_dump.c | 3 + > drivers/gpu/drm/i915/display/intel_display.c | 7 +- > .../drm/i915/display/intel_display_debugfs.c | 4 + > .../drm/i915/display/intel_display_types.h | 23 ----- > drivers/gpu/drm/i915/display/intel_dp.c | 51 ++++++----- > drivers/gpu/drm/i915/display/intel_dp_mst.c | 26 +++--- > drivers/gpu/drm/i915/display/intel_fdi.c | 6 +- > drivers/gpu/drm/i915/display/intel_link_bw.c | 4 +- > drivers/gpu/drm/i915/display/intel_vdsc.c | 51 ++++++----- > drivers/gpu/drm/i915/display/intel_vdsc.h | 4 + > include/drm/display/drm_dsc_helper.h | 3 + > include/drm/drm_fixed.h | 23 +++++ > 18 files changed, 222 insertions(+), 103 deletions(-) -- Jani Nikula, Intel