Hi Doug, On Tue, Jun 11, 2024 at 7:33 PM Doug Anderson <dianders@xxxxxxxxxxxx> wrote: > On Wed, May 29, 2024 at 5:16 AM Geert Uytterhoeven > <geert+renesas@xxxxxxxxx> wrote: > > > > From: Douglas Anderson <dianders@xxxxxxxxxxxx> > > > > Based on grepping through the source code, this driver appears to be > > missing a call to drm_atomic_helper_shutdown() at system shutdown time. > > This is important because drm_helper_force_disable_all() will cause > > panels to get disabled cleanly which may be important for their power > > sequencing. Future changes will remove any custom powering off in > > individual panel drivers so the DRM drivers need to start getting this > > right. > > > > The fact that we should call drm_atomic_helper_shutdown() in the case of > > OS shutdown comes straight out of the kernel doc "driver instance > > overview" in drm_drv.c. > > > > Suggested-by: Maxime Ripard <mripard@xxxxxxxxxx> > > Signed-off-by: Douglas Anderson <dianders@xxxxxxxxxxxx> > > Link: https://lore.kernel.org/r/20230901164111.RFT.15.Iaf638a1d4c8b3c307a6192efabb4cbb06b195f15@changeid > > [geert: s/drm_helper_force_disable_all/drm_atomic_helper_shutdown/] > > [geert: shmob_drm_remove() already calls drm_atomic_helper_shutdown] > > Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx> > > Reviewed-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > --- > > v2: > > - Add Reviewed-by. > > > > Tested on Atmark Techno Armadillo-800-EVA. > > --- > > drivers/gpu/drm/renesas/shmobile/shmob_drm_drv.c | 8 ++++++++ > > 1 file changed, 8 insertions(+) > > FWIW: I've created a patch to list DRM modeset drivers that handle > shutdown properly [1]. For now "shmob-drm" is not part of that > patchset. Assuming my patch lands we'll have to later add it to the > list. Ouch, keeping such a list is ugly ;-) > [1] https://lore.kernel.org/r/20240611074846.1.Ieb287c2c3ee3f6d3b0d5f49b29f746b93621749c@changeid > > I will also note that the subject/description of this patch could be > adjusted. They still reference "drm_helper_force_disable_all" which > should have been changed to "drm_atomic_helper_shutdown". Thanks, v3 sent. Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds