On Thu, May 30, 2024 at 03:06:19PM +0530, Aradhya Bhatia wrote: > Change the existing (and deprecated) bridge hooks, to the bridge > atomic APIs. > > Add drm helpers for duplicate_state, destroy_state, and bridge_reset > bridge hooks. > > Further add support for the input format negotiation hook. > > Signed-off-by: Aradhya Bhatia <a-bhatia1@xxxxxx> > --- > .../gpu/drm/bridge/cadence/cdns-dsi-core.c | 70 ++++++++++++++++--- > 1 file changed, 62 insertions(+), 8 deletions(-) Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx> Minor nit below. > > @@ -915,13 +920,62 @@ static void cdns_dsi_bridge_pre_enable(struct drm_bridge *bridge) > cdns_dsi_hs_init(dsi); > } > > +static u32 *cdns_dsi_bridge_get_input_bus_fmts(struct drm_bridge *bridge, > + struct drm_bridge_state *bridge_state, > + struct drm_crtc_state *crtc_state, > + struct drm_connector_state *conn_state, > + u32 output_fmt, > + unsigned int *num_input_fmts) > +{ This code below looks pretty generic. Would be logical to extract it to a helper and allow it to be used by other DSI host bridges? > + struct cdns_dsi_input *input = bridge_to_cdns_dsi_input(bridge); > + struct cdns_dsi *dsi = input_to_dsi(input); > + struct cdns_dsi_output *output = &dsi->output; > + u32 *input_fmts; > + > + *num_input_fmts = 0; > + > + input_fmts = kzalloc(sizeof(*input_fmts), GFP_KERNEL); > + if (!input_fmts) > + return NULL; > + > + switch (output->dev->format) { > + case MIPI_DSI_FMT_RGB888: > + input_fmts[0] = MEDIA_BUS_FMT_RGB888_1X24; > + break; > + > + case MIPI_DSI_FMT_RGB666: > + input_fmts[0] = MEDIA_BUS_FMT_RGB666_1X24_CPADHI; > + break; > + > + case MIPI_DSI_FMT_RGB666_PACKED: > + input_fmts[0] = MEDIA_BUS_FMT_RGB666_1X18; > + break; > + > + case MIPI_DSI_FMT_RGB565: > + input_fmts[0] = MEDIA_BUS_FMT_RGB565_1X16; > + break; > + > + default: > + /* Unsupported DSI Format */ > + return NULL; > + } > + > + *num_input_fmts = 1; > + > + return input_fmts; > +} > + -- With best wishes Dmitry