Re: [PATCH v4 05/11] drm/ci: mediatek: Refactor existing mediatek jobs

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Helen,

On 07/03/24 19:32, Helen Koike wrote:


On 06/03/2024 00:06, Vignesh Raman wrote:
For mediatek mt8173 and mt8183, the display driver is mediatek.
Currently, in drm-ci for mediatek, only the display driver is
tested. Refactor the existing mediatek jobs so that gpu driver
testing jobs can be added later and update xfails accordingly.
Since the correct driver name is passed from the job to test gpu
and display driver, remove the check to set IGT_FORCE_DRIVER
based on driver name.

Signed-off-by: Vignesh Raman <vignesh.raman@xxxxxxxxxxxxx>
---

v2:
   - Refactor the patch to rename job to indicate display driver testing,
     rename the existing xfail files, and remove IGT_FORCE_DRIVER from the
     script since it's now set by the job.

v3:
   - Add the job name in GPU_VERSION and use it for xfail file names instead
     of using DRIVER_NAME. Also update xfails.

v4:
   - Remove the display suffix in job and rename xfails accordingly.
     Remove the change adding job name in GPU_VERSION.

---
  drivers/gpu/drm/ci/igt_runner.sh              | 10 ---------
  drivers/gpu/drm/ci/test.yml                   | 21 ++++++++++++++-----
  .../drm/ci/xfails/mediatek-mt8173-fails.txt   | 15 -------------
  .../drm/ci/xfails/mediatek-mt8173-flakes.txt  | 13 ++++++++++++
  .../drm/ci/xfails/mediatek-mt8183-fails.txt   | 21 ++++++++++++-------
  .../drm/ci/xfails/mediatek-mt8183-flakes.txt  |  8 +++++++
  6 files changed, 50 insertions(+), 38 deletions(-)
  create mode 100644 drivers/gpu/drm/ci/xfails/mediatek-mt8173-flakes.txt
  create mode 100644 drivers/gpu/drm/ci/xfails/mediatek-mt8183-flakes.txt

diff --git a/drivers/gpu/drm/ci/igt_runner.sh b/drivers/gpu/drm/ci/igt_runner.sh
index 77cd81fe6d1a..711f32772e48 100755
--- a/drivers/gpu/drm/ci/igt_runner.sh
+++ b/drivers/gpu/drm/ci/igt_runner.sh
@@ -20,16 +20,6 @@ cat /sys/kernel/debug/dri/*/state
  set -e
  case "$DRIVER_NAME" in
-    rockchip|meson)
-        export IGT_FORCE_DRIVER="panfrost"
-        ;;
-    mediatek)
-        if [ "$GPU_VERSION" = "mt8173" ]; then
-            export IGT_FORCE_DRIVER=${DRIVER_NAME}
-        elif [ "$GPU_VERSION" = "mt8183" ]; then
-            export IGT_FORCE_DRIVER="panfrost"
-        fi
-        ;;
      amdgpu)
          # Cannot use HWCI_KERNEL_MODULES as at that point we don't have the module in /lib
          mv /install/modules/lib/modules/* /lib/modules/.
diff --git a/drivers/gpu/drm/ci/test.yml b/drivers/gpu/drm/ci/test.yml
index 0857773e5c5f..f8f48523ada3 100644
--- a/drivers/gpu/drm/ci/test.yml
+++ b/drivers/gpu/drm/ci/test.yml
@@ -282,29 +282,40 @@ amdgpu:stoney:
      - .lava-igt:arm64
    stage: mediatek
    variables:
-    DRIVER_NAME: mediatek
      DTB: ${DEVICE_TYPE}
      BOOT_METHOD: depthcharge
      KERNEL_IMAGE_TYPE: ""
-mediatek:mt8173:
+.mt8173:
    extends:
      - .mediatek
    parallel: 4
    variables:
      DEVICE_TYPE: mt8173-elm-hana
-    GPU_VERSION: mt8173

Looks like it make sense to keep GPU_VERSION here, no?
Same comment for .mt8183.

Yes, will keep the GPU_VERSION here for mediatek jobs and others also.

Regards,
Vignesh




[Index of Archives]     [Linux DRI Users]     [Linux Intel Graphics]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux