On Sun, Jan 14, 2024 at 05:25:08PM +0200, Andy Shevchenko wrote: > Convert the module to be property provider agnostic and allow > it to be used on non-OF platforms. > > Include mod_devicetable.h explicitly to replace the dropped of.h > which included mod_devicetable.h indirectly. > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > --- > drivers/video/backlight/hx8357.c | 14 ++++++++------ > 1 file changed, 8 insertions(+), 6 deletions(-) > > diff --git a/drivers/video/backlight/hx8357.c b/drivers/video/backlight/hx8357.c > index bf18337ff0c2..c7fd10d55c5d 100644 > --- a/drivers/video/backlight/hx8357.c > +++ b/drivers/video/backlight/hx8357.c > @@ -8,9 +8,9 @@ > #include <linux/delay.h> > #include <linux/gpio/consumer.h> > #include <linux/lcd.h> > +#include <linux/mod_devicetable.h> > #include <linux/module.h> > -#include <linux/of.h> > -#include <linux/of_device.h> > +#include <linux/property.h> > #include <linux/spi/spi.h> > > #define HX8357_NUM_IM_PINS 3 > @@ -564,6 +564,8 @@ static struct lcd_ops hx8357_ops = { > .get_power = hx8357_get_power, > }; > > +typedef int (*hx8357_init)(struct lcd_device *); > + > static const struct of_device_id hx8357_dt_ids[] = { > { > .compatible = "himax,hx8357", > @@ -582,7 +584,7 @@ static int hx8357_probe(struct spi_device *spi) > struct device *dev = &spi->dev; > struct lcd_device *lcdev; > struct hx8357_data *lcd; > - const struct of_device_id *match; > + hx8357_init init; As somewhere else in this thread, I'd find this a lot more readable as: hx8357_init_fn init_fn; Other than that, LGTM. Daniel.