On 12/15/2023 11:05 AM, Jeffrey Hugo wrote:
On 12/8/2023 9:34 AM, Jeffrey Hugo wrote:
A set of cleanups to the driver to improve error cases and reduce some
code duplication.
Jeffrey Hugo (2):
accel/qaic: Fix MHI channel struct field order
accel/qaic: Order pci_remove() operations in reverse of probe()
Pranjal Ramajor Asha Kanojiya (5):
accel/qaic: Deprecate ->size field from attach slice IOCTL structure
accel/qaic: Remove bo->queued field
accel/qaic: Drop the reference to BO in error path of create BO IOCTL
accel/qaic: Call drm_gem_create_mmap_offset() once for each BO
accel/qaic: Leverage DRM managed APIs to release resources
drivers/accel/qaic/mhi_controller.c | 4 +-
drivers/accel/qaic/qaic.h | 3 +-
drivers/accel/qaic/qaic_data.c | 59 ++++++------
drivers/accel/qaic/qaic_drv.c | 140 ++++++++++++++++++----------
include/uapi/drm/qaic_accel.h | 13 +--
5 files changed, 119 insertions(+), 100 deletions(-)
1-5 pushed to drm-misc-next
-Jeff
6 and 7 pushed to drm-misc-next
-Jeff