On Thu, Dec 14, 2023 at 09:51:13PM +0200, Andy Shevchenko wrote: > Convert the module to be property provider agnostic and allow > it to be used on non-OF platforms. > > Add mod_devicetable.h include. > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > --- > drivers/video/backlight/mp3309c.c | 38 ++++++++++++------------------- > 1 file changed, 15 insertions(+), 23 deletions(-) > > diff --git a/drivers/video/backlight/mp3309c.c b/drivers/video/backlight/mp3309c.c > index 34d71259fac1..d9b08f191999 100644 > --- a/drivers/video/backlight/mp3309c.c > +++ b/drivers/video/backlight/mp3309c.c > @@ -15,6 +15,8 @@ > #include <linux/delay.h> > #include <linux/gpio/consumer.h> > #include <linux/i2c.h> > +#include <linux/mod_devicetable.h> > +#include <linux/property.h> > #include <linux/pwm.h> > #include <linux/regmap.h> > > @@ -202,15 +204,12 @@ static const struct backlight_ops mp3309c_bl_ops = { > static int pm3309c_parse_dt_node(struct mp3309c_chip *chip, Pretty minor... but I wonder if it should be renamed: mp3309c_parse_fwnode(). Daniel.