On 03/11/2023 23:03, Dmitry Baryshkov wrote:
Use the freshly defined DRM_AUX_HPD_BRIDGE instead of open-coding the
same functionality for the DRM bridge chain termination.
Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx>
+ bridge_dev = drm_dp_hpd_bridge_register(tcpm->dev, to_of_node(tcpm->tcpc.fwnode));
+ if (IS_ERR(bridge_dev))
+ return PTR_ERR(bridge_dev);
+
What is the effect if we never attach any bridged devices ?
We make an aux device that just hangs around and eventually get cleaned
up on release ? That's the way I read this code anyway.
Acked-by: Bryan O'Donoghue <bryan.odonoghue@xxxxxxxxxx>