On 9/7/23 13:03, Dan Carpenter wrote: > 2c607edf57db6a Dmitry Osipenko 2023-09-03 @724 if (page_offset >= num_pages || (!shmem->pages && !shmem->evicted)) { > ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ > Should this be || instead of &&? (The other thing that people do is > add "!shmem->evicted" for readability even though it doesn't need to be > checked. So maybe that's the issue, but the checker assumes it needs to > be checked). > > d611b4a0907cec Neil Roberts 2021-02-23 725 ret = VM_FAULT_SIGBUS; > d611b4a0907cec Neil Roberts 2021-02-23 726 } else { > 2c607edf57db6a Dmitry Osipenko 2023-09-03 727 err = drm_gem_shmem_swapin_locked(shmem); > > Or maybe it's because the kbuild bot can't use the cross function db > and shmem->pages is assigned here? Should be a function db problem. The shmem->pages won't be NULL if drm_gem_shmem_swapin_locked() succeeds. -- Best regards, Dmitry