Quoting Dmitry Baryshkov (2023-09-03 15:40:49) > On 29/08/2023 21:47, Stephen Boyd wrote: > > This function is simply drm_dp_is_branch() so use that instead of > > open-coding it. > > > > Cc: Vinod Polimera <quic_vpolimer@xxxxxxxxxxx> > > Cc: Kuogee Hsieh <quic_khsieh@xxxxxxxxxxx> > > Signed-off-by: Stephen Boyd <swboyd@xxxxxxxxxxxx> > > --- > > drivers/gpu/drm/msm/dp/dp_display.c | 9 +-------- > > 1 file changed, 1 insertion(+), 8 deletions(-) > > Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx> Thanks. > > > > > diff --git a/drivers/gpu/drm/msm/dp/dp_display.c b/drivers/gpu/drm/msm/dp/dp_display.c > > index 76f13954015b..96bbf6fec2f1 100644 > > --- a/drivers/gpu/drm/msm/dp/dp_display.c > > +++ b/drivers/gpu/drm/msm/dp/dp_display.c > > @@ -341,19 +341,12 @@ static const struct component_ops dp_display_comp_ops = { > > .unbind = dp_display_unbind, > > }; > > > > -static bool dp_display_is_ds_bridge(struct dp_panel *panel) > > -{ > > - return (panel->dpcd[DP_DOWNSTREAMPORT_PRESENT] & > > - DP_DWN_STRM_PORT_PRESENT); > > -} > > - > > static bool dp_display_is_sink_count_zero(struct dp_display_private *dp) > > Nit: you might as well inline this function Ok. I'll send a followup to this series with a patch for that. I found that with an Apple dongle it always prints out a message to the kernel log when I have HDMI disconnected that there isn't a sink connected, which is annoying. So at least two more patches are incoming.