From: Andrew Morton > Sent: 03 August 2023 18:25 > > On Thu, 3 Aug 2023 16:19:18 +0300 Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote: > > > abs_diff() belongs to math.h. Move it there. > > This will allow others to use it. > > > > ... > > > > --- a/include/linux/math.h > > +++ b/include/linux/math.h > > @@ -155,6 +155,13 @@ __STRUCT_FRACT(u32) > > __builtin_types_compatible_p(typeof(x), unsigned type), \ > > ({ signed type __x = (x); __x < 0 ? -__x : __x; }), other) > > > > +#define abs_diff(a, b) ({ \ > > + typeof(a) __a = (a); \ > > + typeof(b) __b = (b); \ > > + (void)(&__a == &__b); \ > > + __a > __b ? (__a - __b) : (__b - __a); \ > > +}) > > Can we document it please? > > Also, the open-coded type comparison could be replaced with __typecheck()? > > And why the heck isn't __typecheck() in typecheck.h, to be included by > minmax.h. And why would you want to use __typecheck() anyway? It pretty much isn't the test you are looking for. If you are trying to explicitly avoid converting negative value to large positive unsigned ones then you want something like: is_signed_type(typeof(a)) == is_signed_type(typeof(b)) but it isn't even that simple :-) David - Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK Registration No: 1397386 (Wales)