Hi Andrzej, On Mon, Jul 17, 2023 at 08:21:40PM +0200, Andrzej Hajda wrote: > On 17.07.2023 19:30, Andi Shyti wrote: > > In preparation of the next patch allign with the datasheet (BSPEC > > 47112) with the naming of the pipe control set of flag values. > > The variable "flags" in gen12_emit_flush_rcs() is applied as a > > set of flags called Bit Group 1. > > > > Define also the Bit Group 0 as bit_group_0 where currently only > > PIPE_CONTROL0_HDC_PIPELINE_FLUSH bit is set. > > > > Signed-off-by: Andi Shyti <andi.shyti@xxxxxxxxxxxxxxx> > > Cc: <stable@xxxxxxxxxxxxxxx> # v5.8+ > > --- > > drivers/gpu/drm/i915/gt/gen8_engine_cs.c | 34 +++++++++++++----------- > > 1 file changed, 18 insertions(+), 16 deletions(-) > > > > diff --git a/drivers/gpu/drm/i915/gt/gen8_engine_cs.c b/drivers/gpu/drm/i915/gt/gen8_engine_cs.c > > index bee3b7dc595cf..3c935d6b68bf0 100644 > > --- a/drivers/gpu/drm/i915/gt/gen8_engine_cs.c > > +++ b/drivers/gpu/drm/i915/gt/gen8_engine_cs.c > > @@ -210,7 +210,8 @@ int gen12_emit_flush_rcs(struct i915_request *rq, u32 mode) > > mode |= EMIT_FLUSH; > > if (mode & EMIT_FLUSH) { > > - u32 flags = 0; > > + u32 bit_group_0 = 0; > > + u32 bit_group_1 = 0; > > For me flags0 and flags1 seems more readable as in > *gen8_emit_pipe_control(batch, flags0, flags1, offset), but no strong > feelings, but if bit_group is chosen arguments of *gen8_emit_pipe_control > could be changed as well. yes, I thought to update all of them, as well for consistency. I like the name bit_group_0/1 because it's similar to the datasheet. I had some confusion about it earlier and I think this can help to improve readability. Will update all the other functions, as well. > Reviewed-by: Andrzej Hajda <andrzej.hajda@xxxxxxxxx> Thanks! Andi