Shortening the absurdly long recipient list, Google won't let me send this otherwise. On Wed, Jul 12, 2023 at 05:34:28PM +0300, Jani Nikula wrote: > On Wed, 12 Jul 2023, Uwe Kleine-König <u.kleine-koenig@xxxxxxxxxxxxxx> wrote: > > Hello, > > > > while I debugged an issue in the imx-lcdc driver I was constantly > > irritated about struct drm_device pointer variables being named "dev" > > because with that name I usually expect a struct device pointer. > > > > I think there is a big benefit when these are all renamed to "drm_dev". > > I have no strong preference here though, so "drmdev" or "drm" are fine > > for me, too. Let the bikesheding begin! > > > > Some statistics: > > > > $ git grep -ohE 'struct drm_device *\* *[^ (),;]*' v6.5-rc1 | sort | uniq -c | sort -n > > 1 struct drm_device *adev_to_drm > > 1 struct drm_device *drm_ > > 1 struct drm_device *drm_dev > > 1 struct drm_device *drm_dev > > 1 struct drm_device *pdev > > 1 struct drm_device *rdev > > 1 struct drm_device *vdev > > 2 struct drm_device *dcss_drv_dev_to_drm > > 2 struct drm_device **ddev > > 2 struct drm_device *drm_dev_alloc > > 2 struct drm_device *mock > > 2 struct drm_device *p_ddev > > 5 struct drm_device *device > > 9 struct drm_device * dev > > 25 struct drm_device *d > > 95 struct drm_device * > > 216 struct drm_device *ddev > > 234 struct drm_device *drm_dev > > 611 struct drm_device *drm > > 4190 struct drm_device *dev > > > > This series starts with renaming struct drm_crtc::dev to drm_dev. If > > it's not only me and others like the result of this effort it should be > > followed up by adapting the other structs and the individual usages in > > the different drivers. > > I think this is an unnecessary change. In drm, a dev is usually a drm > device, i.e. struct drm_device *. As shown by the numbers above. I fully agree with this. I can understand that this is potentially confusing to people that work across subsystems and aren't used to seeing this. But to most DRM/KMS developers this is quite familiar and since they spend much more time on this than the occasional cross-kernel patch, it outweighs the minor nuisance that this may be for everyone else. Since Uwe has already shown that "dev" is the consensus, I think if we really must have this kind of patch the logical choice would be to change any struct drm_device * to be named "dev" rather than trying to establish a new consensus. > If folks insist on following through with this anyway, I'm firmly in the > camp the name should be "drm" and nothing else. Same here. If people can't live with "dev", then simply "drm" seems like the next best choice. It's short and to the point. A _dev suffix is redundant because any other DRM structure variables will typically be named something else anyway (i.e. crtc, connector, encoder, plane, ... or a corresponding abbreviated form). Thierry
Attachment:
signature.asc
Description: PGP signature