Prepare dropping the alias "dev" for struct drm_crtc::drm_dev. "drm_dev" is the better name as "dev" is usually a struct device pointer. No semantic changes. Signed-off-by: Uwe Kleine-König <u.kleine-koenig@xxxxxxxxxxxxxx> --- drivers/gpu/drm/gud/gud_pipe.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/gud/gud_pipe.c b/drivers/gpu/drm/gud/gud_pipe.c index dc16a92625d4..98b27a736e86 100644 --- a/drivers/gpu/drm/gud/gud_pipe.c +++ b/drivers/gpu/drm/gud/gud_pipe.c @@ -444,7 +444,7 @@ int gud_pipe_check(struct drm_simple_display_pipe *pipe, struct drm_plane_state *new_plane_state, struct drm_crtc_state *new_crtc_state) { - struct gud_device *gdrm = to_gud_device(pipe->crtc.dev); + struct gud_device *gdrm = to_gud_device(pipe->crtc.drm_dev); struct drm_plane_state *old_plane_state = pipe->plane.state; const struct drm_display_mode *mode = &new_crtc_state->mode; struct drm_atomic_state *state = new_plane_state->state; @@ -489,7 +489,7 @@ int gud_pipe_check(struct drm_simple_display_pipe *pipe, if (!connector_state) { struct drm_connector_list_iter conn_iter; - drm_connector_list_iter_begin(pipe->crtc.dev, &conn_iter); + drm_connector_list_iter_begin(pipe->crtc.drm_dev, &conn_iter); drm_for_each_connector_iter(connector, &conn_iter) { if (connector->state->crtc) { connector_state = connector->state; @@ -559,7 +559,7 @@ int gud_pipe_check(struct drm_simple_display_pipe *pipe, void gud_pipe_update(struct drm_simple_display_pipe *pipe, struct drm_plane_state *old_state) { - struct drm_device *drm = pipe->crtc.dev; + struct drm_device *drm = pipe->crtc.drm_dev; struct gud_device *gdrm = to_gud_device(drm); struct drm_plane_state *state = pipe->plane.state; struct drm_shadow_plane_state *shadow_plane_state = to_drm_shadow_plane_state(state); -- 2.39.2