Hi Thomas! On Mon, 2023-07-10 at 14:50 +0200, Thomas Zimmermann wrote: > FBINFO_FLAG_DEFAULT is a flag for a framebuffer in struct fb_info. > Flags for videomodes are prefixed with FB_MODE_. FBINFO_FLAG_DEFAULT > is 0 and the static declaration already clears the memory area of > sh7763fb_videomode. So remove the assignment. > > Signed-off-by: Thomas Zimmermann <tzimmermann@xxxxxxx> > Cc: Yoshinori Sato <ysato@xxxxxxxxxxxxxxxxxxxx> > Cc: Rich Felker <dalias@xxxxxxxx> > Cc: John Paul Adrian Glaubitz <glaubitz@xxxxxxxxxxxxxxxxxxx> > --- > arch/sh/boards/mach-sh7763rdp/setup.c | 1 - > 1 file changed, 1 deletion(-) > > diff --git a/arch/sh/boards/mach-sh7763rdp/setup.c b/arch/sh/boards/mach-sh7763rdp/setup.c > index 97e715e4e9b3..345f2b76c85a 100644 > --- a/arch/sh/boards/mach-sh7763rdp/setup.c > +++ b/arch/sh/boards/mach-sh7763rdp/setup.c > @@ -119,7 +119,6 @@ static struct fb_videomode sh7763fb_videomode = { > .vsync_len = 1, > .sync = 0, > .vmode = FB_VMODE_NONINTERLACED, > - .flag = FBINFO_FLAG_DEFAULT, > }; > > static struct sh7760fb_platdata sh7763fb_def_pdata = { I would argue that the current code is more readable that your proposed change. I agree that it's a no-op, but code is not just about functionality but also readability, isn't it? Also, I prefer "sh:" as the architecture prefix, not "arch/sh:". Thanks, Adrian -- .''`. John Paul Adrian Glaubitz : :' : Debian Developer `. `' Physicist `- GPG: 62FF 8A75 84E0 2956 9546 0006 7426 3B37 F5B5 F913