Re: [PATCH v1] gpu: i915: display: Replace define function

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, 06 Jul 2023, Minjie Du <duminjie@xxxxxxxx> wrote:
> Replace DEFINE_SIMPLE_ATTRIBUTE with DEFINE_DEBUGFS_ATTRIBUTE.

The subject prefix should be "drm/i915/psr: ". Please try git log on the
file to see what is commonly used.

The subject should say what's being done. "Replace define function" is
way too generic to be useful. Even "Prefer DEFINE_DEBUGFS_ATTRIBUTE" is
better.

Finally, the commit message itself should say *why*. Why are we
replacing DEFINE_SIMPLE_ATTRIBUTE with DEFINE_DEBUGFS_ATTRIBUTE?

BR,
Jani.

>
> Signed-off-by: Minjie Du <duminjie@xxxxxxxx>
> ---
>  drivers/gpu/drm/i915/display/intel_psr.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/i915/display/intel_psr.c b/drivers/gpu/drm/i915/display/intel_psr.c
> index 56c17283b..822858f3e 100644
> --- a/drivers/gpu/drm/i915/display/intel_psr.c
> +++ b/drivers/gpu/drm/i915/display/intel_psr.c
> @@ -2998,7 +2998,7 @@ i915_edp_psr_debug_get(void *data, u64 *val)
>  	return -ENODEV;
>  }
>  
> -DEFINE_SIMPLE_ATTRIBUTE(i915_edp_psr_debug_fops,
> +DEFINE_DEBUGFS_ATTRIBUTE(i915_edp_psr_debug_fops,
>  			i915_edp_psr_debug_get, i915_edp_psr_debug_set,
>  			"%llu\n");

-- 
Jani Nikula, Intel Open Source Graphics Center



[Index of Archives]     [Linux DRI Users]     [Linux Intel Graphics]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux