Hi Thomas, On Tue, Apr 25, 2023 at 4:28 PM Thomas Zimmermann <tzimmermann@xxxxxxx> wrote: > Implement DRM fbdev helpers for reading and writing framebuffer > memory with the respective fbdev functions. Removes duplicate > code. > > Signed-off-by: Thomas Zimmermann <tzimmermann@xxxxxxx> Thanks for your patch! > --- a/drivers/gpu/drm/drm_fb_helper.c > +++ b/drivers/gpu/drm/drm_fb_helper.c > @@ -816,21 +727,10 @@ static ssize_t drm_fb_helper_read_screen_buffer(struct fb_info *info, char __use > ssize_t drm_fb_helper_sys_read(struct fb_info *info, char __user *buf, > size_t count, loff_t *ppos) > { > - return __drm_fb_helper_read(info, buf, count, ppos, drm_fb_helper_read_screen_buffer); > + return fb_sys_read(info, buf, count, ppos); > } > EXPORT_SYMBOL(drm_fb_helper_sys_read); I guess drm_fb_helper_sys_read() can just be removed? > @@ -849,7 +749,7 @@ ssize_t drm_fb_helper_sys_write(struct fb_info *info, const char __user *buf, > ssize_t ret; > struct drm_rect damage_area; > > - ret = __drm_fb_helper_write(info, buf, count, ppos, drm_fb_helper_write_screen_buffer); > + ret = fb_sys_write(info, buf, count, ppos); > if (ret <= 0) > return ret; > drm_fb_helper_sys_write() cannot be removed yet, because it does damage handling below. If the fb_ops.fb_sync() callback would be enhanced to pass a region, drm_fb_helper could implement .fb_sync() instead of .fb_write(). Likewise for the "cfb" (which is a misnomer) variants below. Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds