On Mon, Apr 03, 2023 at 09:07:35AM -0700, Rob Clark wrote: > From: Rob Clark <robdclark@xxxxxxxxxxxx> > > What does vblank have to do with num_crtcs? Well, this was technically > correct, but you'd have to go look at where num_crtcs is initialized to > understand why. Lets just replace it with the simpler and more obvious > check. If you want to fix this, then I think the right fix is to rename num_crtcs to be something like num_vblank_crtcs. It's a historical accident back when vblanks without kms was a thing. Plan B is someone gets really busy and fixes up the entire vblank mess and moves it into drm_crtc struct. Now that the dri1 drivers are gone we could indeed do that. Or maybe instead a patch to improve the kerneldoc for drm_dev->num_crtc? -Daniel > Signed-off-by: Rob Clark <robdclark@xxxxxxxxxxxx> > --- > drivers/gpu/drm/drm_vblank.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/drm_vblank.c b/drivers/gpu/drm/drm_vblank.c > index 877e2067534f..ad34c235d853 100644 > --- a/drivers/gpu/drm/drm_vblank.c > +++ b/drivers/gpu/drm/drm_vblank.c > @@ -575,7 +575,7 @@ EXPORT_SYMBOL(drm_vblank_init); > */ > bool drm_dev_has_vblank(const struct drm_device *dev) > { > - return dev->num_crtcs != 0; > + return !!dev->vblank; > } > EXPORT_SYMBOL(drm_dev_has_vblank); > > -- > 2.39.2 > -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch