I collected the, from my POW, uncontroversial patches from V1 of the TTM shrinker series, some corrected after the initial patch submission, one patch added from the Xe RFC ("drm/ttm: Don't print error message if eviction was interrupted"). It would be nice to have these reviewed and merged while reworking the rest. v2: - Simplify __ttm_pool_free(). - Fix the TTM_TT_FLAG bit numbers. - Keep all allocation orders for TTM pages at or below PMD order v3: - Rename __tm_pool_free() to ttm_pool_free_range(). Document. - Compile-fix. Thomas Hellström (3): drm/ttm/pool: Fix ttm_pool_alloc error path drm/ttm: Reduce the number of used allocation orders for TTM pages drm/ttm: Make the call to ttm_tt_populate() interruptible when faulting drivers/gpu/drm/ttm/ttm_bo_vm.c | 13 +++- drivers/gpu/drm/ttm/ttm_pool.c | 111 ++++++++++++++++++++------------ 2 files changed, 80 insertions(+), 44 deletions(-) -- 2.39.2