Hi Ye, Thank you for the patch. On Wed, Mar 22, 2023 at 04:25:25PM +0800, ye.xingchen@xxxxxxxxxx wrote: > From: Ye Xingchen <ye.xingchen@xxxxxxxxxx> > > Replace the open-code with dev_err_probe() to simplify the code. > > Signed-off-by: Ye Xingchen <ye.xingchen@xxxxxxxxxx> > --- > drivers/gpu/drm/xlnx/zynqmp_dp.c | 6 ++---- > 1 file changed, 2 insertions(+), 4 deletions(-) > > diff --git a/drivers/gpu/drm/xlnx/zynqmp_dp.c b/drivers/gpu/drm/xlnx/zynqmp_dp.c > index 0a7b466446fb..c6c2cb4626b9 100644 > --- a/drivers/gpu/drm/xlnx/zynqmp_dp.c > +++ b/drivers/gpu/drm/xlnx/zynqmp_dp.c > @@ -1700,10 +1700,8 @@ int zynqmp_dp_probe(struct zynqmp_dpsub *dpsub) > > dp->reset = devm_reset_control_get(dp->dev, NULL); > if (IS_ERR(dp->reset)) { > - if (PTR_ERR(dp->reset) != -EPROBE_DEFER) > - dev_err(dp->dev, "failed to get reset: %ld\n", > - PTR_ERR(dp->reset)); > - ret = PTR_ERR(dp->reset); > + ret = dev_err_probe(dp->dev, PTR_ERR(dp->reset), > + "failed to get reset: %ld\n"); There's no format string argument anymore, so you should drop the ": %ld". Didn't the compiler warn about this ? > goto err_free; > } > -- Regards, Laurent Pinchart