On 09/03/2023 15:22, Alexandre Mergnat wrote: > From: Fabien Parent <fparent@xxxxxxxxxxxx> > > DPI for MT8365 is compatible with MT8192 but requires an additional > clock. Modify the documentation to requires this clock only on MT8365 SoCs. > > Signed-off-by: Fabien Parent <fparent@xxxxxxxxxxxx> > Signed-off-by: Alexandre Mergnat <amergnat@xxxxxxxxxxxx> > --- > .../bindings/display/mediatek/mediatek,dpi.yaml | 48 ++++++++++++++++++---- > 1 file changed, 39 insertions(+), 9 deletions(-) > > diff --git a/Documentation/devicetree/bindings/display/mediatek/mediatek,dpi.yaml b/Documentation/devicetree/bindings/display/mediatek/mediatek,dpi.yaml > index 56511c4d4b9b..3f6cca81340c 100644 > --- a/Documentation/devicetree/bindings/display/mediatek/mediatek,dpi.yaml > +++ b/Documentation/devicetree/bindings/display/mediatek/mediatek,dpi.yaml > @@ -17,15 +17,20 @@ description: | > > properties: > compatible: > - enum: > - - mediatek,mt2701-dpi > - - mediatek,mt7623-dpi > - - mediatek,mt8173-dpi > - - mediatek,mt8183-dpi > - - mediatek,mt8186-dpi > - - mediatek,mt8188-dp-intf > - - mediatek,mt8192-dpi > - - mediatek,mt8195-dp-intf > + oneOf: > + - enum: > + - mediatek,mt2701-dpi > + - mediatek,mt7623-dpi > + - mediatek,mt8173-dpi > + - mediatek,mt8183-dpi > + - mediatek,mt8186-dpi > + - mediatek,mt8188-dp-intf > + - mediatek,mt8192-dpi > + - mediatek,mt8195-dp-intf > + - items: > + - enum: > + - mediatek,mt8365-dpi > + - const: mediatek,mt8192-dpi > > reg: > maxItems: 1 > @@ -34,16 +39,20 @@ properties: > maxItems: 1 > > clocks: > + minItems: 3 > items: > - description: Pixel Clock > - description: Engine Clock > - description: DPI PLL > + - description: DPI Clock > > clock-names: > + minItems: 3 > items: > - const: pixel > - const: engine > - const: pll > + - const: dpi > > pinctrl-0: true > pinctrl-1: true > @@ -72,6 +81,27 @@ required: > > additionalProperties: false > > +allOf: > + - if: > + properties: > + compatible: > + contains: > + const: mediatek,mt8365-dpi > + > + then: > + properties: > + clocks: > + maxItems: 4 We usually set minItems, so it is clear readable that you raise the lower bracket. Code should be equivalent, but I would say this is less readable (maxItems: 4 was actually implied by top-level list). Best regards, Krzysztof