Add a helper function and make drivers that have the same logic in their struct drm_crtc_helper_funcs .atomic_check handler to use this instead. Patch #1 and #2 are just cleanups for the simpledrm and ssd130x drivers respectively, so that these can be converted to use the helper added by patch #3. The changes are inspired by a patch from Thomas Zimmermann for the ast DRM driver: https://patchwork.kernel.org/project/dri-devel/patch/20221010103625.19958-4-tzimmermann@xxxxxxx/ Best regards, Javier Javier Martinez Canillas (3): drm/simpledrm: Do not call drm_atomic_add_affected_planes() drm/ssd130x: Do not call drm_atomic_add_affected_planes() drm/crtc-helper: Add a drm_crtc_helper_atomic_check() helper drivers/gpu/drm/drm_crtc_helper.c | 24 ++++++++++++++++++++++++ drivers/gpu/drm/solomon/ssd130x.c | 20 ++------------------ drivers/gpu/drm/tiny/simpledrm.c | 20 ++------------------ include/drm/drm_crtc_helper.h | 2 ++ 4 files changed, 30 insertions(+), 36 deletions(-) -- 2.37.3