On Mon, Sep 19, 2022 at 10:25:19AM +0200, Maxime Ripard wrote: > On Mon, Sep 19, 2022 at 10:18:01AM +0200, José Expósito wrote: > > Hi Maxime, > > > > Thanks for looking into the patches. > > > > On Mon, Sep 19, 2022 at 09:36:45AM +0200, Maxime Ripard wrote: > > > Hi, > > > > > > On Mon, Sep 19, 2022 at 09:15:31AM +0200, José Expósito wrote: > > > > Extend the existing test cases to test the conversion from XRGB8888 to > > > > grayscale. > > > > > > > > Tested-by: Maíra Canal <mairacanal@xxxxxxxxxx> > > > > Reviewed-by: David Gow <davidgow@xxxxxxxxxx> > > > > Signed-off-by: José Expósito <jose.exposito89@xxxxxxxxx> > > > > --- > > > > .../gpu/drm/tests/drm_format_helper_test.c | 62 +++++++++++++++++++ > > > > 1 file changed, 62 insertions(+) > > > > > > > > diff --git a/drivers/gpu/drm/tests/drm_format_helper_test.c b/drivers/gpu/drm/tests/drm_format_helper_test.c > > > > index 09d358b54da0..71722e828abe 100644 > > > > --- a/drivers/gpu/drm/tests/drm_format_helper_test.c > > > > +++ b/drivers/gpu/drm/tests/drm_format_helper_test.c > > > > @@ -37,6 +37,11 @@ struct convert_to_xrgb2101010_result { > > > > const u32 expected[TEST_BUF_SIZE]; > > > > }; > > > > > > > > +struct convert_to_gray8_result { > > > > + unsigned int dst_pitch; > > > > + const u8 expected[TEST_BUF_SIZE]; > > > > +}; > > > > + > > > > > > > > [...] > > > > > > > > static struct kunit_case drm_format_helper_test_cases[] = { > > > > KUNIT_CASE_PARAM(drm_test_fb_xrgb8888_to_rgb332, convert_xrgb8888_gen_params), > > > > KUNIT_CASE_PARAM(drm_test_fb_xrgb8888_to_rgb565, convert_xrgb8888_gen_params), > > > > KUNIT_CASE_PARAM(drm_test_fb_xrgb8888_to_rgb888_test, convert_xrgb8888_gen_params), > > > > KUNIT_CASE_PARAM(drm_test_fb_xrgb8888_to_xrgb2101010_test, convert_xrgb8888_gen_params), > > > > + KUNIT_CASE_PARAM(drm_test_fb_xrgb8888_to_gray8_test, convert_xrgb8888_gen_params), > > > > > > The trailing test feels redundant, > > > > Why do you feel like it is redundant? Under the hood, most conversion > > functions reuse the same code, but the *_line() function is unique and > > I think that it is worth testing it. > > Sure, I wasn't commenting on the code itself, but the trailing "test" in > the test name: drm_test_fb_xrgb8888_to_gray8_test > ^ > > Which is redundant since we already have "test" in the prefix. > > Maxime Ah! OK, I misunderstood your first sentence. Indeed, the _test sufix should be removed, added to my TODO list. Thanks!!