On Monday, 29 August 2022 02:09:18 CEST Isabella Basso wrote: > This change makes `igt_module_unload_r` safer as it checks whether the s/igt_module_unload_r/igt_kmod_unload_r/ > module can be unloaded before attempting it. > > Signed-off-by: Isabella Basso <isabbasso@xxxxxxxxxx> > --- > lib/igt_kmod.c | 3 +++ > 1 file changed, 3 insertions(+) > > diff --git a/lib/igt_kmod.c b/lib/igt_kmod.c > index bb6cb7bb..97cac7f5 100644 > --- a/lib/igt_kmod.c > +++ b/lib/igt_kmod.c > @@ -256,6 +256,9 @@ static int igt_kmod_unload_r(struct kmod_module *kmod, unsigned int flags) > struct kmod_list *holders, *pos; > int err = 0; > > + if (kmod_module_get_initstate(kmod) == KMOD_MODULE_BUILTIN) > + return err; NIT: I think that return 0; would be more clear. Anyway, Acked-by: Janusz Krzysztofik <janusz.krzysztofik@xxxxxxxxxxxxxxx> > + > holders = kmod_module_get_holders(kmod); > kmod_list_foreach(pos, holders) { > struct kmod_module *it = kmod_module_get_module(pos); >