On Wed, Apr 27, 2022, Maxim Levitsky wrote: > This will be used to enable write tracking from nested AVIC code > and can also be used to enable write tracking in GVT-g module > when it actually uses it as opposed to always enabling it, > when the module is compiled in the kernel. Wrap at ~75. > No functional change intended. > > Signed-off-by: Maxim Levitsky <mlevitsk@xxxxxxxxxx> > --- > arch/x86/include/asm/kvm_host.h | 2 +- > arch/x86/include/asm/kvm_page_track.h | 1 + > arch/x86/kvm/mmu.h | 8 +++++--- > arch/x86/kvm/mmu/mmu.c | 17 ++++++++++------- > arch/x86/kvm/mmu/page_track.c | 10 ++++++++-- > 5 files changed, 25 insertions(+), 13 deletions(-) > > diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h > index 636df87542555..fc7df778a3d71 100644 > --- a/arch/x86/include/asm/kvm_host.h > +++ b/arch/x86/include/asm/kvm_host.h > @@ -1254,7 +1254,7 @@ struct kvm_arch { > * is used as one input when determining whether certain memslot > * related allocations are necessary. > */ The above comment needs to be rewritten. > - bool shadow_root_allocated; > + bool mmu_page_tracking_enabled; > #if IS_ENABLED(CONFIG_HYPERV) > hpa_t hv_root_tdp; > diff --git a/arch/x86/include/asm/kvm_page_track.h b/arch/x86/include/asm/kvm_page_track.h > index eb186bc57f6a9..955a5ae07b10e 100644 > --- a/arch/x86/include/asm/kvm_page_track.h > +++ b/arch/x86/include/asm/kvm_page_track.h > @@ -50,6 +50,7 @@ int kvm_page_track_init(struct kvm *kvm); > void kvm_page_track_cleanup(struct kvm *kvm); > > bool kvm_page_track_write_tracking_enabled(struct kvm *kvm); > +int kvm_page_track_write_tracking_enable(struct kvm *kvm); > int kvm_page_track_write_tracking_alloc(struct kvm_memory_slot *slot); > > void kvm_page_track_free_memslot(struct kvm_memory_slot *slot); > diff --git a/arch/x86/kvm/mmu.h b/arch/x86/kvm/mmu.h > index 671cfeccf04e9..44d15551f7156 100644 > --- a/arch/x86/kvm/mmu.h > +++ b/arch/x86/kvm/mmu.h > @@ -269,7 +269,7 @@ int kvm_arch_write_log_dirty(struct kvm_vcpu *vcpu); > int kvm_mmu_post_init_vm(struct kvm *kvm); > void kvm_mmu_pre_destroy_vm(struct kvm *kvm); > > -static inline bool kvm_shadow_root_allocated(struct kvm *kvm) > +static inline bool mmu_page_tracking_enabled(struct kvm *kvm) > { > /* > * Read shadow_root_allocated before related pointers. Hence, threads > @@ -277,9 +277,11 @@ static inline bool kvm_shadow_root_allocated(struct kvm *kvm) > * see the pointers. Pairs with smp_store_release in > * mmu_first_shadow_root_alloc. > */ This comment also needs to be rewritten. > - return smp_load_acquire(&kvm->arch.shadow_root_allocated); > + return smp_load_acquire(&kvm->arch.mmu_page_tracking_enabled); > } ... > diff --git a/arch/x86/kvm/mmu/page_track.c b/arch/x86/kvm/mmu/page_track.c > index 2e09d1b6249f3..8857d629036d7 100644 > --- a/arch/x86/kvm/mmu/page_track.c > +++ b/arch/x86/kvm/mmu/page_track.c > @@ -21,10 +21,16 @@ > > bool kvm_page_track_write_tracking_enabled(struct kvm *kvm) This can be static, it's now used only by page_track.c. > { > - return IS_ENABLED(CONFIG_KVM_EXTERNAL_WRITE_TRACKING) || > - !tdp_enabled || kvm_shadow_root_allocated(kvm); > + return mmu_page_tracking_enabled(kvm); > } > > +int kvm_page_track_write_tracking_enable(struct kvm *kvm) This is too similar to the "enabled" version; "kvm_page_track_enable_write_tracking()" would maintain namespacing and be less confusing. Hmm, I'd probably vote to make this a "static inline" in kvm_page_track.h, and rename mmu_enable_write_tracking() to kvm_mmu_enable_write_tracking and export. Not a strong preference, just feels silly to export a one-liner. > +{ > + return mmu_enable_write_tracking(kvm); > +} > +EXPORT_SYMBOL_GPL(kvm_page_track_write_tracking_enable); > + > + > void kvm_page_track_free_memslot(struct kvm_memory_slot *slot) > { > int i; > -- > 2.26.3 >