Le 04/03/2022 à 21:24, Lyude Paul a écrit : > This mostly looks good to me. Just one question (and one comment down below > that needs addressing). Is this with ppc32? (I ask because ppc64le doesn't > seem to hit this compilation error). That's with PPC64, see http://kisskb.ellerman.id.au/kisskb/branch/chleroy/head/252ba609bea83234d2e35841c19ae84c67b43ec7/ But that's not (yet) with the mainline tree. That's work I'm doing to cleanup our asm/asm-protoypes.h header. Since commit 4efca4ed05cb ("kbuild: modversions for EXPORT_SYMBOL() for asm") that file is dedicated to prototypes of functions defined in assembly. Therefore I'm trying to dispatch C functions prototypes in other headers. I wanted to move prom_init() prototype into asm/prom.h and then I hit the problem. In the beginning I was thinking about just changing the name of the function in powerpc, but as I see that M68K, MIPS and SPARC also have a prom_init() function, I thought it would be better to change the name in shadowrom.c to avoid any future conflict like the one I got while reworking the headers. >> @@ -57,8 +57,8 @@ prom_init(struct nvkm_bios *bios, const char *name) >> const struct nvbios_source >> nvbios_rom = { >> .name = "PROM", >> - .init = prom_init, >> - .fini = prom_fini, >> - .read = prom_read, >> + .init = nvbios_rom_init, >> + .fini = nvbios_rom_fini, >> + .read = nvbios_rom_read, > > Seeing as the source name is prom, I think using the naming convention > nvbios_prom_* would be better then nvbios_rom_*. > Yes I wasn't sure about the best naming as the file name is shadowrom.c and not shadowprom.c. I will send v2 using nvbios_prom_* as a name. Christophe