Hi Bjorn, 1. I will change the edp_out label to mdss_edp_out. 2. The "pm8350c_pwm" node is part of the dependent series mentioned in the cover letter. Below is the patch for the same: https://patchwork.kernel.org/project/linux-arm-msm/patch/1637917920-22041-4-git-send-email-quic_c_skakit@xxxxxxxxxxx/ 3. I will move the edp_backlight and edp_panel nodes to the root. Thank you, Sankeerth -----Original Message----- From: Bjorn Andersson <bjorn.andersson@xxxxxxxxxx> Sent: Wednesday, February 9, 2022 5:23 AM To: Sankeerth Billakanti (QUIC) <quic_sbillaka@xxxxxxxxxxx> Cc: dri-devel@xxxxxxxxxxxxxxxxxxxxx; linux-arm-msm@xxxxxxxxxxxxxxx; freedreno@xxxxxxxxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; devicetree@xxxxxxxxxxxxxxx; agross@xxxxxxxxxx; robh+dt@xxxxxxxxxx; robdclark@xxxxxxxxx; seanpaul@xxxxxxxxxxxx; swboyd@xxxxxxxxxxxx; dianders@xxxxxxxxxxxx; krzysztof.kozlowski@xxxxxxxxxxxxx; thierry.reding@xxxxxxxxx; sam@xxxxxxxxxxxx; airlied@xxxxxxxx; daniel@xxxxxxxx; quic_kalyant <quic_kalyant@xxxxxxxxxxx>; Abhinav Kumar (QUIC) <quic_abhinavk@xxxxxxxxxxx>; Kuogee Hsieh (QUIC) <quic_khsieh@xxxxxxxxxxx>; quic_mkrishn <quic_mkrishn@xxxxxxxxxxx> Subject: Re: [PATCH v2 2/4] arm64: dts: qcom: sc7280: Add support for eDP panel on CRD On Tue 08 Feb 07:18 PST 2022, Sankeerth Billakanti wrote: > Enable the eDP display panel support without HPD on sc7280 platform. > > Signed-off-by: Sankeerth Billakanti <quic_sbillaka@xxxxxxxxxxx> > --- > > Changes in v2: > - sort node references alphabetically > - improve readability > - move the pwm pinctrl to pwm node > - move the regulators to root > - define backlight power > - remove dummy regulator node > - cleanup pinctrl definitions > > arch/arm64/boot/dts/qcom/sc7280-crd.dts | 122 ++++++++++++++++++++++++++++++++ > arch/arm64/boot/dts/qcom/sc7280.dtsi | 2 - > 2 files changed, 122 insertions(+), 2 deletions(-) > > diff --git a/arch/arm64/boot/dts/qcom/sc7280-crd.dts > b/arch/arm64/boot/dts/qcom/sc7280-crd.dts > index e2efbdd..bff2707 100644 > --- a/arch/arm64/boot/dts/qcom/sc7280-crd.dts > +++ b/arch/arm64/boot/dts/qcom/sc7280-crd.dts > @@ -21,6 +21,34 @@ > chosen { > stdout-path = "serial0:115200n8"; > }; > + > + backlight_power: backlight-power { > + compatible = "regulator-fixed"; > + regulator-name = "backlight_power"; > + > + regulator-min-microvolt = <1800000>; > + regulator-max-microvolt = <1800000>; > + > + gpio = <&pm8350c_gpios 7 GPIO_ACTIVE_HIGH>; > + enable-active-high; > + > + pinctrl-names = "default"; > + pinctrl-0 = <&edp_bl_power>; > + }; > + > + edp_power: edp-power { > + compatible = "regulator-fixed"; > + regulator-name = "edp_power"; > + > + regulator-min-microvolt = <3300000>; > + regulator-max-microvolt = <3300000>; > + > + gpio = <&tlmm 80 GPIO_ACTIVE_HIGH>; > + enable-active-high; > + > + pinctrl-names = "default"; > + pinctrl-0 = <&edp_panel_power>; > + }; > }; > > &apps_rsc { > @@ -76,6 +104,42 @@ ap_ts_pen_1v8: &i2c13 { > }; > }; > > +&edp_out { Sorry for missing this while merging changes in sc7280.dtsi. But it would be really nice if this was labeled mdss_edp_out instead (or possibly defined within the &mdss_edp node). Now you will have &edp_out and &dp_out floating around away from the edp and dp nodes... > + remote-endpoint = <&edp_panel_in>; > +}; > + > +&mdss { > + status = "okay"; > +}; > + > +&mdss_edp { > + status = "okay"; > + > + vdda-1p2-supply = <&vreg_l6b_1p2>; > + vdda-0p9-supply = <&vreg_l10c_0p8>; > +}; > + > +&mdss_edp_phy { > + status = "okay"; > + > + vdda-1p2-supply = <&vreg_l6b_1p2>; > + vdda-0p9-supply = <&vreg_l10c_0p8>; > +}; > + > +&mdss_dp { > + status = "okay"; > + > + pinctrl-names = "default"; > + pinctrl-0 = <&dp_hot_plug_det>; > + data-lanes = <0 1>; > + vdda-1p2-supply = <&vreg_l6b_1p2>; > + vdda-0p9-supply = <&vreg_l1b_0p8>; > +}; > + > +&mdss_mdp { > + status = "okay"; > +}; > + > &nvme_3v3_regulator { > gpio = <&tlmm 51 GPIO_ACTIVE_HIGH>; > }; > @@ -84,7 +148,65 @@ ap_ts_pen_1v8: &i2c13 { > pins = "gpio51"; > }; > > +&pm8350c_pwm { This label doesn't exist, so I won't be able to merge this patch. > + status = "okay"; > + > + pinctrl-names = "default"; > + pinctrl-0 = <&edp_bl_pwm>; > +}; > + > +&pm8350c_gpios { > + edp_bl_power: edp-bl-power { > + pins = "gpio7"; > + function = "normal"; > + qcom,drive-strength = <PMIC_GPIO_STRENGTH_LOW>; > + bias-disable; > + output-low; > + }; > + > + edp_bl_pwm: edp-bl-pwm { > + pins = "gpio8"; > + function = "func1"; > + qcom,drive-strength = <PMIC_GPIO_STRENGTH_LOW>; > + bias-disable; > + output-low; > + }; > +}; > + > +&soc { > + edp_backlight: edp-backlight { > + compatible = "pwm-backlight"; This is not a device on the mmio bus, so it should not love within the &soc. > + > + power-supply = <&backlight_power>; > + pwms = <&pm8350c_pwm 3 65535>; > + }; > + > + edp_panel: edp_panel { Ditto. Regards, Bjorn > + compatible = "sharp,lq140m1jw46"; > + > + power-supply = <&edp_power>; > + backlight = <&edp_backlight>; > + > + ports { > + #address-cells = <1>; > + #size-cells = <0>; > + port@0 { > + reg = <0>; > + edp_panel_in: endpoint { > + remote-endpoint = <&edp_out>; > + }; > + }; > + }; > + }; > +}; > + > &tlmm { > + edp_panel_power: edp-panel-power { > + pins = "gpio80"; > + function = "gpio"; > + bias-pull-down; > + }; > + > tp_int_odl: tp-int-odl { > pins = "gpio7"; > function = "gpio"; > diff --git a/arch/arm64/boot/dts/qcom/sc7280.dtsi > b/arch/arm64/boot/dts/qcom/sc7280.dtsi > index 3572399..f8fa716 100644 > --- a/arch/arm64/boot/dts/qcom/sc7280.dtsi > +++ b/arch/arm64/boot/dts/qcom/sc7280.dtsi > @@ -3012,8 +3012,6 @@ > > mdss_edp: edp@aea0000 { > compatible = "qcom,sc7280-edp"; > - pinctrl-names = "default"; > - pinctrl-0 = <&edp_hot_plug_det>; > > reg = <0 0xaea0000 0 0x200>, > <0 0xaea0200 0 0x200>, > -- > 2.7.4 >