Hi, > > +#define for_each_gt(i915__, id__, gt__) \ > > + for ((id__) = 0; \ > > + (id__) < I915_MAX_TILES; \ > > + (id__)++) \ > > + for_each_if(((gt__) = (i915__)->gts[(id__)])) > > In this patch set, symbol I915_MAX_TILES is introduced. > In a later patch set of this series, I915_MAX_TILES is renamed to I915_MAX_GTS. > How about using name I915_MAX_GTS consistently through the patch series? > > It will make the history easier to understand, and should this patch series > be merged in pieces, it will avoid having to do the rename in software that > depends on this. speaking of which I915_MAX_GTS is not a great choice of a name: as Jani pointed out in one of his prevoius reviews, how do we intrepret it, GTS or GTs? Andi