On Sat, Aug 28, 2021 at 4:51 AM Cai Huoqing <caihuoqing@xxxxxxxxx> wrote: > > Use the helper macro SET_RUNTIME_PM_OPS() instead of the verbose > operators ".runtime_suspend/.runtime_resume/.runtime_idle", because > the SET_RUNTIME_PM_OPS() is a nice helper macro that could be brought > in to make code a little clearer, a little more concise. I don't personally think it really helps readability. Just seems to be code churn. Alex > > Signed-off-by: Cai Huoqing <caihuoqing@xxxxxxxxx> > --- > drivers/gpu/drm/radeon/radeon_drv.c | 5 ++--- > 1 file changed, 2 insertions(+), 3 deletions(-) > > diff --git a/drivers/gpu/drm/radeon/radeon_drv.c b/drivers/gpu/drm/radeon/radeon_drv.c > index b74cebca1f89..c2eb725e87f6 100644 > --- a/drivers/gpu/drm/radeon/radeon_drv.c > +++ b/drivers/gpu/drm/radeon/radeon_drv.c > @@ -529,15 +529,14 @@ static long radeon_kms_compat_ioctl(struct file *filp, unsigned int cmd, unsigne > #endif > > static const struct dev_pm_ops radeon_pm_ops = { > + SET_RUNTIME_PM_OPS(radeon_pmops_runtime_suspend, > + radeon_pmops_runtime_resume, radeon_pmops_runtime_idle) > .suspend = radeon_pmops_suspend, > .resume = radeon_pmops_resume, > .freeze = radeon_pmops_freeze, > .thaw = radeon_pmops_thaw, > .poweroff = radeon_pmops_freeze, > .restore = radeon_pmops_resume, > - .runtime_suspend = radeon_pmops_runtime_suspend, > - .runtime_resume = radeon_pmops_runtime_resume, > - .runtime_idle = radeon_pmops_runtime_idle, > }; > > static const struct file_operations radeon_driver_kms_fops = { > -- > 2.25.1 >