On Sun, Jul 11, 2021 at 10:45:48AM -0700, Joe Perches wrote: > On Sun, 2021-07-11 at 19:24 +0200, Len Baker wrote: > > The branches of the "if" statement are the same. So remove the > > unnecessary if and goto statements. > > > > Addresses-Coverity-ID: 1456916 ("Identical code for different branches") > > Fixes: 4c283fdac08ab ("drm/amd/display: Add HDCP module") > > Signed-off-by: Len Baker <len.baker@xxxxxxx> > > I'm not a big fan of this type of change. > > It's currently the same style used for six tests in this function > and changing this last one would just make it harder to see the > code blocks as consistent. > > I doubt any reasonable compiler would produce different objects. Ok, thanks for the review. I leave it as is. > > diff --git a/drivers/gpu/drm/amd/display/modules/hdcp/hdcp1_execution.c b/drivers/gpu/drm/amd/display/modules/hdcp/hdcp1_execution.c > [] > > @@ -305,10 +305,8 @@ static enum mod_hdcp_status wait_for_ready(struct mod_hdcp *hdcp, > > hdcp, "bcaps_read")) > > goto out; > > } > > - if (!mod_hdcp_execute_and_set(check_ksv_ready, > > - &input->ready_check, &status, > > - hdcp, "ready_check")) > > - goto out; > > + mod_hdcp_execute_and_set(check_ksv_ready, &input->ready_check, &status, > > + hdcp, "ready_check"); > > out: > > return status; > > } > > -- > > 2.25.1 > > Thanks, Len