Hi Lee, Thank you for the patch. On Wed, Jun 02, 2021 at 03:32:52PM +0100, Lee Jones wrote: > Fixes the following W=1 kernel build warning(s): > > drivers/gpu/drm/xlnx/zynqmp_dp.c:806: warning: expecting prototype for zynqmp_dp_link_train(). Prototype was for zynqmp_dp_train() instead > > Cc: Hyun Kwon <hyun.kwon@xxxxxxxxxx> > Cc: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > Cc: David Airlie <airlied@xxxxxxxx> > Cc: Daniel Vetter <daniel@xxxxxxxx> > Cc: Michal Simek <michal.simek@xxxxxxxxxx> > Cc: Philipp Zabel <p.zabel@xxxxxxxxxxxxxx> > Cc: dri-devel@xxxxxxxxxxxxxxxxxxxxx > Cc: linux-arm-kernel@xxxxxxxxxxxxxxxxxxx > Signed-off-by: Lee Jones <lee.jones@xxxxxxxxxx> > --- > drivers/gpu/drm/xlnx/zynqmp_dp.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/xlnx/zynqmp_dp.c b/drivers/gpu/drm/xlnx/zynqmp_dp.c > index 82430ca9b9133..a1055d5055eab 100644 > --- a/drivers/gpu/drm/xlnx/zynqmp_dp.c > +++ b/drivers/gpu/drm/xlnx/zynqmp_dp.c > @@ -797,7 +797,7 @@ static int zynqmp_dp_link_train_ce(struct zynqmp_dp *dp) > } > > /** > - * zynqmp_dp_link_train - Train the link > + * zynqmp_dp_train - Train the link The driver has other functions related to link training that start with the zynqmp_dp_link_train_* prefix. I'd prefer renaming this function to zynqmp_dp_link_train(). Bonus points if the same patch could rename zynqmp_dp_train_loop() to zynqmp_dp_link_train_loop() too :-) > * @dp: DisplayPort IP core structure > * > * Return: 0 if all trains are done successfully, or corresponding error code. -- Regards, Laurent Pinchart