On Fri, 26 Mar 2021, Lyude Paul <lyude@xxxxxxxxxx> wrote: > * The @dev field should be set to a pointer to the device that implements the > - * AUX channel. > + * AUX channel. As well, the @drm_dev field should be set to the &drm_device > + * that will be using this AUX channel as early as possible. For many graphics > + * drivers this should happen before drm_dp_aux_init(), however it's perfectly > + * fine to set this field later so long as it's assigned before calling > + * drm_dp_aux_register(). Perhaps add a follow-up patch to actually ensure this is the case in drm_dp_aux_register()? > * > * The @name field may be used to specify the name of the I2C adapter. If set to > * %NULL, dev_name() of @dev will be used. > @@ -1877,6 +1883,7 @@ struct drm_dp_aux { > const char *name; > struct i2c_adapter ddc; > struct device *dev; > + struct drm_device *drm_dev; Bikeshed, I would probably have called it just drm for brevity, but no strong feelings. BR, Jani. -- Jani Nikula, Intel Open Source Graphics Center _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel