Thomas Gleixner @ 2020-12-06 09:38 MST: > On Fri, Dec 04 2020 at 18:43, Jerry Snitselaar wrote: > >> Now that kstat_irqs is exported, get rid of count_interrupts in >> i915_pmu.c >> --- a/drivers/gpu/drm/i915/i915_pmu.c >> +++ b/drivers/gpu/drm/i915/i915_pmu.c >> @@ -423,22 +423,6 @@ static enum hrtimer_restart i915_sample(struct hrtimer *hrtimer) >> return HRTIMER_RESTART; >> } >> >> -static u64 count_interrupts(struct drm_i915_private *i915) >> -{ >> - /* open-coded kstat_irqs() */ >> - struct irq_desc *desc = irq_to_desc(i915->drm.pdev->irq); >> - u64 sum = 0; >> - int cpu; >> - >> - if (!desc || !desc->kstat_irqs) >> - return 0; >> - >> - for_each_possible_cpu(cpu) >> - sum += *per_cpu_ptr(desc->kstat_irqs, cpu); >> - >> - return sum; >> -} > > May I ask why this has been merged in the first place? > > Nothing in a driver has ever to fiddle with the internals of an irq > descriptor. We have functions for properly accessing them. Just because > C allows to fiddle with everything is not a justification. If the > required function is not exported then adding the export with a proper > explanation is not asked too much. > > Also this lacks protection or at least a comment why this can be called > safely and is not subject to a concurrent removal of the irq descriptor. > The same problem exists when calling kstat_irqs(). It's even documented > at the top of the function. > > Thanks, > > tglx I don't know the history behind this bit. I stumbled across it in cscope when looking for places using kstat_irqs. _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel