Reviewed-by: Bas Nieuwenhuizen <bas@xxxxxxxxxxxxxxxxxxx> On Mon, Oct 26, 2020 at 2:17 PM Simon Ser <contact@xxxxxxxxxxx> wrote: > > DRM_FORMAT_MOD_NONE is in the list of vendors, which is pretty > confusing. We already have DRM_FORMAT_MOD_VENDOR_NONE. Move it down in > the list of format modifiers. > > DRM_FORMAT_MOD_NONE is an alias for DRM_FORMAT_MOD_LINEAR, however the > name is confusing: NONE doesn't mean that the modifier is implicit, > instead it means that the layout is linear. Deprecate it. > > Signed-off-by: Simon Ser <contact@xxxxxxxxxxx> > Suggested-by: Bas Nieuwenhuizen <bas@xxxxxxxxxxxxxxxxxxx> > Cc: Daniel Vetter <daniel@xxxxxxxx> > Cc: Pekka Paalanen <ppaalanen@xxxxxxxxx> > --- > include/uapi/drm/drm_fourcc.h | 9 ++++++++- > 1 file changed, 8 insertions(+), 1 deletion(-) > > diff --git a/include/uapi/drm/drm_fourcc.h b/include/uapi/drm/drm_fourcc.h > index d720f1e8ae5e..ca1d5587b5fc 100644 > --- a/include/uapi/drm/drm_fourcc.h > +++ b/include/uapi/drm/drm_fourcc.h > @@ -350,7 +350,6 @@ extern "C" { > */ > > /* Vendor Ids: */ > -#define DRM_FORMAT_MOD_NONE 0 > #define DRM_FORMAT_MOD_VENDOR_NONE 0 > #define DRM_FORMAT_MOD_VENDOR_INTEL 0x01 > #define DRM_FORMAT_MOD_VENDOR_AMD 0x02 > @@ -422,6 +421,14 @@ extern "C" { > */ > #define DRM_FORMAT_MOD_LINEAR fourcc_mod_code(NONE, 0) > > +/* > + * Deprecated: use DRM_FORMAT_MOD_LINEAR instead > + * > + * The "none" format modifier doesn't actually mean that the modifier is > + * implicit, instead it means that the layout is linear. > + */ > +#define DRM_FORMAT_MOD_NONE 0 > + > /* Intel framebuffer modifiers */ > > /* > -- > 2.28.0 > > _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel