Hi, Enric: Enric Balletbo i Serra <enric.balletbo@xxxxxxxxxxxxx> 於 2020年6月16日 週二 上午4:31寫道: > > This is really a cosmetic change just to make a bit more readable the > code after convert the driver to drm_bridge. The bridge variable name > will be used by the encoder drm_bridge, and the chained bridge will be > named next_bridge. > Applied to mediatek-drm-next [1], thanks. [1] https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next Regards, Chun-Kuang. > Signed-off-by: Enric Balletbo i Serra <enric.balletbo@xxxxxxxxxxxxx> > Reviewed-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > Acked-by: Sam Ravnborg <sam@xxxxxxxxxxxx> > Reviewed-by: Chun-Kuang Hu <chunkuang.hu@xxxxxxxxxx> > --- > > Changes in v4: None > Changes in v3: > - Replace s/bridge/next bridge/ for comment. (Laurent Pinchart) > > Changes in v2: None > > drivers/gpu/drm/mediatek/mtk_dsi.c | 11 ++++++----- > 1 file changed, 6 insertions(+), 5 deletions(-) > > diff --git a/drivers/gpu/drm/mediatek/mtk_dsi.c b/drivers/gpu/drm/mediatek/mtk_dsi.c > index 270bf22c98feb..208f49bf14a01 100644 > --- a/drivers/gpu/drm/mediatek/mtk_dsi.c > +++ b/drivers/gpu/drm/mediatek/mtk_dsi.c > @@ -183,7 +183,7 @@ struct mtk_dsi { > struct drm_encoder encoder; > struct drm_connector conn; > struct drm_panel *panel; > - struct drm_bridge *bridge; > + struct drm_bridge *next_bridge; > struct phy *phy; > > void __iomem *regs; > @@ -894,9 +894,10 @@ static int mtk_dsi_create_conn_enc(struct drm_device *drm, struct mtk_dsi *dsi) > */ > dsi->encoder.possible_crtcs = 1; > > - /* If there's a bridge, attach to it and let it create the connector */ > - if (dsi->bridge) { > - ret = drm_bridge_attach(&dsi->encoder, dsi->bridge, NULL, 0); > + /* If there's a next bridge, attach to it and let it create the connector */ > + if (dsi->next_bridge) { > + ret = drm_bridge_attach(&dsi->encoder, dsi->next_bridge, NULL, > + 0); > if (ret) { > DRM_ERROR("Failed to attach bridge to drm\n"); > goto err_encoder_cleanup; > @@ -1177,7 +1178,7 @@ static int mtk_dsi_probe(struct platform_device *pdev) > } > > ret = drm_of_find_panel_or_bridge(dev->of_node, 0, 0, > - &dsi->panel, &dsi->bridge); > + &dsi->panel, &dsi->next_bridge); > if (ret) > goto err_unregister_host; > > -- > 2.27.0 > _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel