On Wed, Nov 13, 2019 at 05:35:41PM +0100, Daniel Vetter wrote: > On Wed, Nov 13, 2019 at 04:58:56PM +0100, Thomas Zimmermann wrote: > > Both functions are deprecated. Open-code them them in preparation > > of removing struct drm_driver.{load,unload}. > > > > Signed-off-by: Thomas Zimmermann <tzimmermann@xxxxxxx> > > --- > > drivers/gpu/drm/ast/ast_drv.c | 31 +++++++++++++++++++++++++++++-- > > 1 file changed, 29 insertions(+), 2 deletions(-) > > > > diff --git a/drivers/gpu/drm/ast/ast_drv.c b/drivers/gpu/drm/ast/ast_drv.c > > index d763da6f0834..78c90a3c903b 100644 > > --- a/drivers/gpu/drm/ast/ast_drv.c > > +++ b/drivers/gpu/drm/ast/ast_drv.c > > @@ -86,9 +86,35 @@ static void ast_kick_out_firmware_fb(struct pci_dev *pdev) > > > > static int ast_pci_probe(struct pci_dev *pdev, const struct pci_device_id *ent) > > { > > + struct drm_device *dev; > > + int ret; > > + > > ast_kick_out_firmware_fb(pdev); > > > > - return drm_get_pci_dev(pdev, ent, &driver); > > + ret = pci_enable_device(pdev); > > + if (ret) > > + return ret; > > + > > + dev = drm_dev_alloc(&driver, &pdev->dev); > > Would be nice to also switch over to embedding drm_device and > drm_dev_init, but for another patch. This is Even better: devm_drm_dev_init, and dropping the drm_dev_put/kfree at the bottom of the pci_remove function. -Daniel > > Reviewed-by: Daniel Vetter <daniel.vetter@xxxxxxxx> > > > + if (IS_ERR(dev)) { > > + ret = PTR_ERR(dev); > > + goto err_pci_disable_device; > > + } > > + > > + dev->pdev = pdev; > > + pci_set_drvdata(pdev, dev); > > + > > + ret = drm_dev_register(dev, ent->driver_data); > > + if (ret) > > + goto err_drm_dev_put; > > + > > + return 0; > > + > > +err_drm_dev_put: > > + drm_dev_put(dev); > > +err_pci_disable_device: > > + pci_disable_device(pdev); > > + return ret; > > } > > > > static void > > @@ -96,7 +122,8 @@ ast_pci_remove(struct pci_dev *pdev) > > { > > struct drm_device *dev = pci_get_drvdata(pdev); > > > > - drm_put_dev(dev); > > + drm_dev_unregister(dev); > > + drm_dev_put(dev); > > } > > > > static int ast_drm_freeze(struct drm_device *dev) > > -- > > 2.23.0 > > > > -- > Daniel Vetter > Software Engineer, Intel Corporation > http://blog.ffwll.ch -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch _______________________________________________ dri-devel mailing list dri-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/dri-devel